summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-04 14:58:45 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-04 15:07:36 -0700
commite0c250293258c8cd4a83fb70324f381d07f486a9 (patch)
tree246760a274b16592533a7d7a61abf457b7c31bd8 /dev-python
parentsci-mathematics/gmm: ppc ppc64 stable (bug 612294). (diff)
downloadgentoo-e0c250293258c8cd4a83fb70324f381d07f486a9.tar.gz
gentoo-e0c250293258c8cd4a83fb70324f381d07f486a9.tar.bz2
gentoo-e0c250293258c8cd4a83fb70324f381d07f486a9.zip
dev-python/pyasn1: version bump to 0.2.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyasn1/Manifest1
-rw-r--r--dev-python/pyasn1/pyasn1-0.2.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyasn1/Manifest b/dev-python/pyasn1/Manifest
index 9e42c8408042..db345db4b74f 100644
--- a/dev-python/pyasn1/Manifest
+++ b/dev-python/pyasn1/Manifest
@@ -1,3 +1,4 @@
DIST pyasn1-0.1.7.tar.gz 68120 SHA256 e4f81d53c533f6bd9526b047f047f7b101c24ab17339c1a7ad8f98b25c101eab SHA512 af2ac05fb7e18b25bd125f92bd7c8389a00c18018c1ff48d94c196f5ab41b09c8991d2e326d492cfaed755b06cd4c75d88719b4a390bdab6d84fe3c8791620af WHIRLPOOL 902b80616cecbf3549417c95ec09c060c6a038f95bd71ce2f9a5c0cd1e4cfd4e9157252abedec3002588eaba5a3cecd7100138c952a5e8f8b7e245b4f82d5c7c
DIST pyasn1-0.1.8.tar.gz 75676 SHA256 5d33be7ca0ec5997d76d29ea4c33b65c00c0231407fff975199d7f40530b8347 SHA512 0a0b9b8018ae80a0e0d84ea3a4f217951bf42dce909a354c97890d4b4fc4f49b19d9d0757103ac9002c17c6c622c8e8d66e1f8242b8545a7da455ef3583acdfa WHIRLPOOL db46e06ef9a6b5858c07f1c154657f998b509c457395b4f2e6286ea90e1b16346e24d92a8d666b5db4216e35129f2d6be13c2fc11aae2d9936163bff3b1400eb
DIST pyasn1-0.1.9.tar.gz 75947 SHA256 853cacd96d1f701ddd67aa03ecc05f51890135b7262e922710112f12a2ed2a7f SHA512 c72bdba84c4cc860a1790d752861dc9de30dabb61e5146a551597b4a97e64797dbd6e575e61cb9a8b23ffc58bced143b0ed55a7c98d0a85834ccd60b17856df5 WHIRLPOOL 2d47a9cf1a04a9f07a053926bd4d317ae71f52e7df88b9be53ff343d1e82770cb5c6709e6fa154e9cf0bb05e47c6c24f6736899bbf41c39a01f6d0211cfb98a5
+DIST pyasn1-0.2.3.tar.gz 100099 SHA256 66c70011074ed6f5a74591591a9f0bed4bc2c2a45baef60f8dcc89ab5da11b9d SHA512 c55b95c1995f2fc36ec28f35837ca456a2fac06e90edc6491a3335ae949e4eacbbeb14f6289a17e994b49d4dc60870bba3e79344c44496d5547c38ab1ef183ab WHIRLPOOL d74142002096d49914e8b15a425764a08c02a43326b9ca1511f4e316fd025c0ce9333c748e010794fe788416b38aa7a1e3460c346524200ba4bd3836297d405c
diff --git a/dev-python/pyasn1/pyasn1-0.2.3.ebuild b/dev-python/pyasn1/pyasn1-0.2.3.ebuild
new file mode 100644
index 000000000000..261dea54fd72
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.2.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1"
+SRC_URI="https://github.com/etingof/pyasn1/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# The required doc/source/conf.py file is missing from the pypi:
+# https://github.com/etingof/pyasn1/issues/35
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test || die "Tests fail with ${EPYTHON}"
+}
+
+src_compile() {
+ if use doc; then
+ python_setup
+ esetup.py build_sphinx
+ fi
+ distutils-r1_src_compile
+}
+
+src_install() {
+ local HTML_DOCS
+ use doc && HTML_DOCS=( build/sphinx/html/. )
+
+ distutils-r1_src_install
+}