summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-14 14:22:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 14:22:39 +0200
commite454d393a2dcd150298a61e9dd21a77ccff4140b (patch)
treee280b06d1c096bb21494e32439de5659f40bf07c /dev-python
parentdev-python/pandas: Unrestrict s3fs dep (diff)
downloadgentoo-e454d393a2dcd150298a61e9dd21a77ccff4140b.tar.gz
gentoo-e454d393a2dcd150298a61e9dd21a77ccff4140b.tar.bz2
gentoo-e454d393a2dcd150298a61e9dd21a77ccff4140b.zip
dev-python/partd: Bump to 1.1.0, py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/partd/Manifest1
-rw-r--r--dev-python/partd/partd-1.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/partd/Manifest b/dev-python/partd/Manifest
index 9b76c11ba226..bc05090cf679 100644
--- a/dev-python/partd/Manifest
+++ b/dev-python/partd/Manifest
@@ -1 +1,2 @@
DIST partd-0.3.8.tar.gz 19171 BLAKE2B 1c96a3771ba8866ec1f8e8536909c433bc2cf914d0eee9ae01bd7d1255b44caed59b1dd71ff4f7c433c3429a86381757be1202dadd01cd65282687ddd0c1ad62 SHA512 3b7c642f7452a409eece356d2fe2e9430f6c5859b685c2ebe3d4cd8fbaa1c86e370174454f31b264ff8866ca9a9ab3bc0ca288f7ed123d8233ea3332f373d01d
+DIST partd-1.1.0.tar.gz 35497 BLAKE2B fb9461daccd5f3215471b201bd30be1fdd499f929490b1819899c7396d1d541fa46c629c26bcef5567df259ef0de1ec8effc3b7b498dec0235a4c0117a1c6014 SHA512 5e26c4a63fc2f9a290b211c1fce291da6b3354b4d0fdf941d29ddad1252629c94275ac360d33c88d11ff4e36a4f4d6bee42edd867c92eb7ef0d2697472c9a338
diff --git a/dev-python/partd/partd-1.1.0.ebuild b/dev-python/partd/partd-1.1.0.ebuild
new file mode 100644
index 000000000000..84f60be5c684
--- /dev/null
+++ b/dev-python/partd/partd-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Appendable key-value storage"
+HOMEPAGE="https://github.com/dask/partd/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/locket[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blosc[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest