summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-11 07:51:02 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-12 19:39:36 +0800
commite6cc592f399a806de8896d04260366de8a893a90 (patch)
tree2f959e3c8f31d04159a40db9823f749a22412730 /dev-python
parentdev-python/enzyme: remove old (diff)
downloadgentoo-e6cc592f399a806de8896d04260366de8a893a90.tar.gz
gentoo-e6cc592f399a806de8896d04260366de8a893a90.tar.bz2
gentoo-e6cc592f399a806de8896d04260366de8a893a90.zip
dev-python/rebulk: new package
Python library that performs advanced searches in strings. Required for the upcoming guessit verbump to 2.0.5. Package-Manager: portage-2.2.28 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rebulk/Manifest1
-rw-r--r--dev-python/rebulk/metadata.xml16
-rw-r--r--dev-python/rebulk/rebulk-0.7.2.ebuild41
-rw-r--r--dev-python/rebulk/rebulk-9999.ebuild41
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/rebulk/Manifest b/dev-python/rebulk/Manifest
new file mode 100644
index 000000000000..576720f4d807
--- /dev/null
+++ b/dev-python/rebulk/Manifest
@@ -0,0 +1 @@
+DIST rebulk-0.7.2.tar.gz 254345 SHA256 ee4c75819c6d0eeedb531fb22c214e50f303ccc4703f27db1f993cd082ed5a20 SHA512 2855b6f754dd258e5e0ba8264cd6993c08fed141fb8b61f88b43beadea9acfcfeb54443c8708fa98de44f2c199dd900e6c9669dc616713dd61d873779f1df2f5 WHIRLPOOL a814772e5d34d6890b1435d652992a9b898435c4075619660351988d1ba955723a8440b8bde6a0c3e6547a465a9b040d085059a7938509a4edc9d7a21318148a
diff --git a/dev-python/rebulk/metadata.xml b/dev-python/rebulk/metadata.xml
new file mode 100644
index 000000000000..da5a8b155c95
--- /dev/null
+++ b/dev-python/rebulk/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Toilal/rebulk</remote-id>
+ <remote-id type="pypi">rebulk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rebulk/rebulk-0.7.2.ebuild b/dev-python/rebulk/rebulk-0.7.2.ebuild
new file mode 100644
index 000000000000..0f97f9d6bf5c
--- /dev/null
+++ b/dev-python/rebulk/rebulk-0.7.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.python.org/pypi/rebulk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/rebulk/rebulk-9999.ebuild b/dev-python/rebulk/rebulk-9999.ebuild
new file mode 100644
index 000000000000..09e77761069f
--- /dev/null
+++ b/dev-python/rebulk/rebulk-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.python.org/pypi/rebulk"
+EGIT_REPO_URI="git://github.com/Toilal/${PN}.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}