summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 17:20:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 18:36:12 +0100
commite72627181398ed9519c862cb15f85e7c9797536f (patch)
tree9dbaa81f3a4b23110e9ac42449e84942dfa94efb /dev-python
parentdev-python/redis-py: Bump to 4.5.1 (diff)
downloadgentoo-e72627181398ed9519c862cb15f85e7c9797536f.tar.gz
gentoo-e72627181398ed9519c862cb15f85e7c9797536f.tar.bz2
gentoo-e72627181398ed9519c862cb15f85e7c9797536f.zip
dev-python/testfixtures: Bump to 7.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-7.1.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 2fa30b114f2f..c454cf0fac54 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-7.0.3.tar.gz 127280 BLAKE2B 14725f5a04a77453f1a6e1cb07b2ee8e907dcf49a845c9c75951d77160448c1037c7bfa0a759cf4061d92448203b8f4b14d611cdde32f46269b484985e654e67 SHA512 875aba5102bd43800b2f6464dc93185cd2bb5e117523cb4b3c458b2f8f8eb71f309c0a5266eeca70a7928f9992ccfe7807c67e42531c17fd82ca1c3b838d02a5
+DIST testfixtures-7.1.0.tar.gz 133026 BLAKE2B 0fbb25e97c06cdd7c94be26c56e96a70847493f71b2f0adc58f333fe2ab930a9bfb6de154a1a23a5cb2cbb1e5e87cb6d9ac95433d357de0689296e33c04078c3 SHA512 d1b2b3ca9674865a45be254a41777c2cba42d4ac3de5d77420d6d33416bfde7ba6a8ca39033cd2c217b0eb81ef5c97bf5b197dd047f9a337bbe1a3da91d9c0ef
diff --git a/dev-python/testfixtures/testfixtures-7.1.0.ebuild b/dev-python/testfixtures/testfixtures-7.1.0.ebuild
new file mode 100644
index 000000000000..d0541a212cd8
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-7.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="
+ https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}