summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-03 10:55:48 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-04 18:13:32 +0100
commiteb29a29c5a5819619d77536c1b111e2aa1c1dc51 (patch)
treeed3ff08441713afcadf220524d02d81d40055ad6 /dev-python
parentdev-python/netaddr: Restrict cli to py3 (diff)
downloadgentoo-eb29a29c5a5819619d77536c1b111e2aa1c1dc51.tar.gz
gentoo-eb29a29c5a5819619d77536c1b111e2aa1c1dc51.tar.bz2
gentoo-eb29a29c5a5819619d77536c1b111e2aa1c1dc51.zip
dev-python/sympy: Remove redundant version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/files/sympy-1.1.1-zeta.patch29
-rw-r--r--dev-python/sympy/sympy-1.1.1.ebuild90
3 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 32de1e038dd0..2b7673282b33 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,2 @@
DIST sympy-1.0.tar.gz 4281528 BLAKE2B b222be6ec486a01ac73e9778a7423aab45e368386003de965308cfa4e08fef07b64046f62ef707b6fa124ee6367fb051b9722e138bfe2eae4661f9e2a66c2365 SHA512 977db6e9bc6a5918cceb255981a57e85e7060c0922aefd2968b004d25d704e25a5cb5bbe09eb387e8695581e23e2825d9c40310068fe25ece7e9c23037a21f39
-DIST sympy-1.1.1.tar.gz 4580952 BLAKE2B 81e5c7d0f80916ced5532f8e5ed3bd04f919b8acb17037237faf9d59cdf73a3a8f741086213fd2aa5a610caf88ae0781c83a0345b71945d69149075b23f09a85 SHA512 ff8857fd5810795554ca4f636b2d8e633057d7ea7df76461003d823ecbaddc98cde0561eb79a1058741c5ece233c13bfcb5e30d5bfb8ac6dbab3d05d8226f92b
DIST sympy-1.3.tar.gz 5885611 BLAKE2B 14b0639960432cd6aac087a57f81a80497a0bc40ed61eae92166cf5549deaefc611ce63c2e7a89922374e9bb902fb0a7402f5a4e425278f34c028cdc3582eb35 SHA512 3b47dcf80e9a0ca7d65860907264bbcd6f6022275c717784cd165a7a824dca3471bc5a3be9d1af6ab31e04b29f7d5305713fc47ccb67f798f45281e0ab7e03bf
diff --git a/dev-python/sympy/files/sympy-1.1.1-zeta.patch b/dev-python/sympy/files/sympy-1.1.1-zeta.patch
deleted file mode 100644
index d9bab8096fac..000000000000
--- a/dev-python/sympy/files/sympy-1.1.1-zeta.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -U2 -r sympy-1.1.1.orig/sympy/functions/special/zeta_functions.py sympy-1.1.1/sympy/functions/special/zeta_functions.py
---- sympy-1.1.1.orig/sympy/functions/special/zeta_functions.py 2017-07-22 05:17:42.000000000 +0700
-+++ sympy-1.1.1/sympy/functions/special/zeta_functions.py 2017-07-28 06:35:28.477927184 +0700
-@@ -272,4 +272,5 @@
- @classmethod
- def eval(cls, s, z):
-+ from sympy import unpolarify
- if z == 1:
- return zeta(s)
-@@ -277,5 +278,11 @@
- return -dirichlet_eta(s)
- elif z == 0:
-- return 0
-+ return S.Zero
-+
-+ # branch handling
-+ if (1 - abs(z)).is_nonnegative:
-+ newz = unpolarify(z)
-+ if newz != z:
-+ return cls(s, newz)
-
- def fdiff(self, argindex=1):
-@@ -483,5 +490,5 @@
- For `\operatorname{Re}(s) > 0`, this function is defined as
-
-- .. math:: \eta(s) = \sum_{n=1}^\infty \frac{(-1)^n}{n^s}.
-+ .. math:: \eta(s) = \sum_{n=1}^\infty \frac{(-1)^{n-1}}{n^s}.
-
- It admits a unique analytic continuation to all of :math:`\mathbb{C}`.
diff --git a/dev-python/sympy/sympy-1.1.1.ebuild b/dev-python/sympy/sympy-1.1.1.ebuild
deleted file mode 100644
index 1c817c1345eb..000000000000
--- a/dev-python/sympy/sympy-1.1.1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1 eutils virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="https://sympy.org"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? (
- dev-libs/libxml2:2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-libs/libxslt[${PYTHON_USEDEP}]' python2_7)
- gtk? ( x11-libs/gtkmathview[gtk] )
- )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
- symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
- theano? ( dev-python/theano[${PYTHON_USEDEP}] )
-"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] app-text/docbook2X )
- test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-zeta.patch
- "${FILESDIR}"/${PN}-1.0-doc-makefile.patch
-)
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
- if use doc; then
- export XDG_CONFIG_HOME="${T}/config-dir"
- mkdir "${XDG_CONFIG_HOME}" || die
- chmod 0700 "${XDG_CONFIG_HOME}" || die
- emake -j1 -C doc html info man cheatsheet
- fi
-}
-
-python_test() {
- virtx "${PYTHON}" setup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- if use doc; then
- DOCS+=( doc/_build/cheatsheet/cheatsheet.pdf \
- doc/_build/cheatsheet/combinatoric_cheatsheet.pdf )
- local HTML_DOCS=( doc/_build/html/. )
- doinfo doc/_build/texinfo/${PN}.info
- fi
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}