summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-09 20:33:54 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-09 20:43:18 +0200
commiteb31b8d49c2bcde6f0562f242c91169c26716a8e (patch)
treeea66a7efb47956a0d7fbf0593a2def178bc88dd5 /dev-python
parentdev-python/google-apputils: Use setup.py to run tests (diff)
downloadgentoo-eb31b8d49c2bcde6f0562f242c91169c26716a8e.tar.gz
gentoo-eb31b8d49c2bcde6f0562f242c91169c26716a8e.tar.bz2
gentoo-eb31b8d49c2bcde6f0562f242c91169c26716a8e.zip
dev-python/google-apputils: Fix namespace support
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-apputils/google-apputils-0.4.2-r2.ebuild b/dev-python/google-apputils/google-apputils-0.4.2-r2.ebuild
new file mode 100644
index 000000000000..e1fb178d2d23
--- /dev/null
+++ b/dev-python/google-apputils/google-apputils-0.4.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# Python 3: https://github.com/google/google-apputils/issues/9
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for building Python applications"
+HOMEPAGE="https://github.com/google/google-apputils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-1.4[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2010[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"
+
+src_unpack() {
+ default
+ chmod -R a+rX,u+w,g-w,o-w ${P} || die
+}
+
+python_test() {
+ esetup.py google_test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}