summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-05-12 20:54:32 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-06-16 09:02:51 +0300
commitece0fd03e7c87d36cb4dbcb016fb927ab31ff955 (patch)
tree8038f558f37ad1f04cec1f38e562a1ea334346aa /dev-python
parentmedia-gfx/viewnior: Update metainfo location; Revbump. (diff)
downloadgentoo-ece0fd03e7c87d36cb4dbcb016fb927ab31ff955.tar.gz
gentoo-ece0fd03e7c87d36cb4dbcb016fb927ab31ff955.tar.bz2
gentoo-ece0fd03e7c87d36cb4dbcb016fb927ab31ff955.zip
dev-python/vdirsyncer: 0.16.8 bump
Bump to EAPI 7. Support Python 3.7 and 3.8. Fix incorrect LICENSE. Closes: https://bugs.gentoo.org/719654 Signed-off-by: Christopher Head <chead@chead.ca> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch35
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild49
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index b57a46d382da..5e0a35b54e03 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1 +1,2 @@
DIST vdirsyncer-0.16.7.tar.gz 112786 BLAKE2B 19b9ce6e3e9de0a626b9562b4d54b270c1532d93169fe2d872f15c6bf6e1ac94bc623c171e51e871082422116636b4945b58dd172cfca527a010906737f1b6a3 SHA512 218c6781139a9e979077308dc732756cc27ecb67966e4b52be31cb1ebf04d224443036102d5c4bad253b9dcf533939f0b72082166f0fe94e042a7e946b8fad0e
+DIST vdirsyncer-0.16.8.tar.gz 115819 BLAKE2B e0140718a1b41875421a7094e02cdeb865c500935e0c97bc18a614551586d79682641726df1a96e17a158604ed309f713f4caf4a484025eca5fbc6acbbe18f97 SHA512 12cb50f592085af37bd9c4207c0d31fdd38fc2a44712eb6288b12e7e7ee9af82070d1d405fa9579e935e545e6c92aafb6f8334ebde4976c4eb9412e78e7c5ada
diff --git a/dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch b/dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch
new file mode 100644
index 000000000000..c0ee62f959f9
--- /dev/null
+++ b/dev-python/vdirsyncer/files/vdirsyncer-0.16.8-click-7-compat.patch
@@ -0,0 +1,35 @@
+commit 3eb9ce5ae4320d52e6c876874511ff96a8a45f51
+Author: Hugo Osvaldo Barrera <hugo@barrera.io>
+Date: Tue Jun 9 14:45:02 2020 +0200
+
+ Add compatibility with latest click
+
+diff --git a/setup.py b/setup.py
+index 59549f16842a..d584b95dd297 100644
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ from setuptools import setup
+
+ requirements = [
+ # https://github.com/mitsuhiko/click/issues/200
+- 'click>=5.0,<6.0',
++ 'click>=5.0',
+ 'click-log>=0.3.0, <0.4.0',
+
+ # https://github.com/pimutils/vdirsyncer/issues/478
+diff --git a/tests/system/cli/test_sync.py b/tests/system/cli/test_sync.py
+index f242376417f3..43d35dd8541e 100644
+--- a/tests/system/cli/test_sync.py
++++ b/tests/system/cli/test_sync.py
+@@ -123,7 +123,10 @@ def test_verbosity(tmpdir, runner):
+ runner.write_with_general('')
+ result = runner.invoke(['--verbosity=HAHA', 'sync'])
+ assert result.exception
+- assert 'invalid value for "--verbosity"' in result.output.lower()
++ assert (
++ 'invalid value for "--verbosity"' in result.output.lower()
++ or "invalid value for '--verbosity'" in result.output.lower()
++ )
+
+
+ def test_collections_cache_invalidation(tmpdir, runner):
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
new file mode 100644
index 000000000000..eba73bc32ea9
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/pimutils/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${P}-click-7-compat.patch" )
+
+RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-5.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+distutils_enable_tests pytest
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}