summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-15 20:16:09 +0000
committerSam James <sam@gentoo.org>2021-06-15 20:16:09 +0000
commitedf6635c38cbd7a59e666b2356b81435298234ce (patch)
treef53234bb595d58e9b8e5b82966eb63190a1ae0d5 /dev-python
parentdev-python/rq: 1.8.0 is incompatible with new Click (diff)
downloadgentoo-edf6635c38cbd7a59e666b2356b81435298234ce.tar.gz
gentoo-edf6635c38cbd7a59e666b2356b81435298234ce.tar.bz2
gentoo-edf6635c38cbd7a59e666b2356b81435298234ce.zip
dev-python/rq: drop 1.8.0-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.8.0-r1.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 47452569ff29..92be7df584ce 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
-DIST rq-1.8.0.tar.gz 584251 BLAKE2B 3da1d4f1604a57e16e26c39643337fb8ab804089f783d6a7c44500f577a326cf4883835c996427e819896faad512b9a380ebfdcf67e865eec475d39321ecd2f5 SHA512 e8946b4454e67bc9ce0c69c302ba3bb6403654cce384904d64996766227ba8fdcbff834a8901a8fa09dcccebe8aba769d38daf228283f4142166fa5ea0f9a107
DIST rq-1.8.1.tar.gz 585211 BLAKE2B 17feb07cb376c5aef88a7aab6d716f58a19f62f19db6c6b0490b4f666981e40304c6a23c88669a0aef9b75a39ce8cb85a9b10a2d42e83e646cdcb6282167d8f9 SHA512 b9df7b4e894a5da693827ff720be3068336d82d2f17928faf5ae6133b042ac2f98a3d673bb2ed86c9351479669e9ef0e4fffcb1dba9b8853f6f793db4a4678f8
diff --git a/dev-python/rq/rq-1.8.0-r1.ebuild b/dev-python/rq/rq-1.8.0-r1.ebuild
deleted file mode 100644
index e929fad06acc..000000000000
--- a/dev-python/rq/rq-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
-SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- <dev-python/click-8.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests --install pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}