summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 01:00:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 01:12:57 +0100
commitef2ba2e94247c98320edd9201fed2d33bf96d66d (patch)
treee6b6757d32d877f9db869619e66413d200d3ab74 /dev-python
parentdev-python/atpublic: Bump to 2.1.3 (diff)
downloadgentoo-ef2ba2e94247c98320edd9201fed2d33bf96d66d.tar.gz
gentoo-ef2ba2e94247c98320edd9201fed2d33bf96d66d.tar.bz2
gentoo-ef2ba2e94247c98320edd9201fed2d33bf96d66d.zip
dev-python/django-auth-ldap: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-2.3.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 79f8d7f469cb..811881272955 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,2 +1,3 @@
DIST django-auth-ldap-2.1.0.tar.gz 51027 BLAKE2B 1229d184746cf05f9c7ddb9e6674b2c529a0fc6d051f78ba01de6a80b0e5e408a8da10e35087efad60f1fef90be708e8a0c05b04c4408500329d9dfb567c0f8b SHA512 4c204eee856e33fae80a22a80bd0f3a21d1f2ee33b1ad56087832f89e91d7e1441579cf77541c1c35e8e0532d4da937b736fe3b4708d7c2d7bbccacbb0b24061
DIST django-auth-ldap-2.2.0.tar.gz 53148 BLAKE2B 1f83a2f174d9fcbd264ce7e298c0dfebc720482b058e55833416440627c9e1fc02f2ad4e585e6fe01102f100337df5835020b8ff48a5dccb850cfff28ef902a0 SHA512 2ed1913e81a4801d683280586018df57067ec84b44299da4c6415452c978c8f1d2ca1d36eaced40efa0737180d7e35971e4570753f60d946b32d846b455ab744
+DIST django-auth-ldap-2.3.0.tar.gz 53383 BLAKE2B a07b487f386cec06b89a90979ef904790fcc1460bf0cab5a5b3539b4fee28cc281487c0db1996ac5b1d2bae756cb8a353fa92796654b689a82a13854cb1be9dd SHA512 08bde0ea25baaf1bcc42b500572e63636ab247a846222d3f16f25874c26c6799b37fa23dc2bfde3dfbcfb041c942ec7a2e7a4e6c7bb391eb3210568f77a8657b
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-2.3.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-2.3.0.ebuild
new file mode 100644
index 000000000000..d87561115bc9
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-2.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://github.com/django-auth-ldap/django-auth-ldap
+ https://pypi.org/project/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ django-admin test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}