summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-16 08:07:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-16 08:08:29 +0200
commitef7eb8d24214ddd4a1a21376d68b9b8054c7ff6b (patch)
tree20ce3aad9067d4e7a8da6bec774d9d63145d6730 /dev-python
parentdev-python/progressbar2: Remove old (diff)
downloadgentoo-ef7eb8d24214ddd4a1a21376d68b9b8054c7ff6b.tar.gz
gentoo-ef7eb8d24214ddd4a1a21376d68b9b8054c7ff6b.tar.bz2
gentoo-ef7eb8d24214ddd4a1a21376d68b9b8054c7ff6b.zip
dev-python/sphinx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/Manifest1
-rw-r--r--dev-python/sphinx/files/sphinx-4.1.2-py310.patch63
-rw-r--r--dev-python/sphinx/sphinx-4.1.2.ebuild133
3 files changed, 0 insertions, 197 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index b23d0c566116..9a7327f0a0e5 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -1,3 +1,2 @@
DIST Sphinx-3.5.4.tar.gz 5911093 BLAKE2B 8740714dfaf3733bf57d0b277315b4e7b5cad86247ea30dcbc4f5dadf5f5169329050b7be43ec8625c47df9dcc19afcc6c4d782725c7007f8178b7eb7be7dc05 SHA512 853379f3b0496772846be9beb072c2c8a69ff899ffe4c6435b448ea639a32138c61403f9c14f62f4f78b2e526a2ee7c05b4196eabdeee37bcae6aa98df992125
-DIST Sphinx-4.1.2.tar.gz 6373677 BLAKE2B a78df4302520898c8708a75129baf28dd2dcde2dcbb4147d8246a2dd7907ae2af2ed8cf1d259ff1065dbe987fd918a7153831a9f5c16e79834c41f86b6031e41 SHA512 1fe998de7b8fc47989e186835748b7fb5d0b523db95434515b6af29b56d28372f2f92ab917c27cbed51aa0cad13175eda8bf4fc93a8726eb5e93e9bc6995e457
DIST Sphinx-4.2.0.tar.gz 6503692 BLAKE2B a3cc73c215be6859f285b92d651f2fe60f731340e7c003d3b275247593d1e641a25618817f67e7f3d8767724d6e98a6d63493bea340c7171e4e3da384da776e2 SHA512 6c6a2424362805b758c43136a9293dcfb02d45af6e6dc2dd7ed9382f6ae04ecfbd416efeecb42219b67d026a4a0b007500e87b20d81847ab48e2ccfcdca52e75
diff --git a/dev-python/sphinx/files/sphinx-4.1.2-py310.patch b/dev-python/sphinx/files/sphinx-4.1.2-py310.patch
deleted file mode 100644
index 8c03d1f66721..000000000000
--- a/dev-python/sphinx/files/sphinx-4.1.2-py310.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 1fd5f746539d3e02886032fae8d53af0c2f6ecdd Mon Sep 17 00:00:00 2001
-From: Takeshi KOMIYA <i.tkomiya@gmail.com>
-Date: Fri, 30 Jul 2021 01:27:38 +0900
-Subject: [PATCH] Fix #9512: sphinx-build: crashed with the HEAD of Python 3.10
-
-Recently, `types.Union` was renamed to `types.UnionType` on the HEAD
-of 3.10 (refs: python/cpython#27342). After this change, sphinx-build
-has been crashed because of ImportError.
----
- CHANGES | 2 ++
- sphinx/util/typing.py | 12 ++++++------
- 2 files changed, 8 insertions(+), 6 deletions(-)
-
-diff --git a/CHANGES b/CHANGES
-index a643bfe841..70eb8db93a 100644
---- a/CHANGES
-+++ b/CHANGES
-@@ -16,6 +16,8 @@ Features added
- Bugs fixed
- ----------
-
-+* #9512: sphinx-build: crashed with the HEAD of Python 3.10
-+
- Testing
- --------
-
-diff --git a/sphinx/util/typing.py b/sphinx/util/typing.py
-index f1723c035a..012d32e524 100644
---- a/sphinx/util/typing.py
-+++ b/sphinx/util/typing.py
-@@ -33,10 +33,10 @@ def _evaluate(self, globalns: Dict, localns: Dict) -> Any:
- ref = _ForwardRef(self.arg)
- return ref._eval_type(globalns, localns)
-
--if sys.version_info > (3, 10):
-- from types import Union as types_Union
--else:
-- types_Union = None
-+try:
-+ from types import UnionType # type: ignore # python 3.10 or above
-+except ImportError:
-+ UnionType = None
-
- if False:
- # For type annotation
-@@ -114,7 +114,7 @@ def restify(cls: Optional[Type]) -> str:
- return ':class:`%s`' % INVALID_BUILTIN_CLASSES[cls]
- elif inspect.isNewType(cls):
- return ':class:`%s`' % cls.__name__
-- elif types_Union and isinstance(cls, types_Union):
-+ elif UnionType and isinstance(cls, UnionType):
- if len(cls.__args__) > 1 and None in cls.__args__:
- args = ' | '.join(restify(a) for a in cls.__args__ if a)
- return 'Optional[%s]' % args
-@@ -337,7 +337,7 @@ def _stringify_py37(annotation: Any) -> str:
- elif hasattr(annotation, '__origin__'):
- # instantiated generic provided by a user
- qualname = stringify(annotation.__origin__)
-- elif types_Union and isinstance(annotation, types_Union): # types.Union (for py3.10+)
-+ elif UnionType and isinstance(annotation, UnionType): # types.Union (for py3.10+)
- qualname = 'types.Union'
- else:
- # we weren't able to extract the base type, appending arguments would
diff --git a/dev-python/sphinx/sphinx-4.1.2.ebuild b/dev-python/sphinx/sphinx-4.1.2.ebuild
deleted file mode 100644
index 03135e278977..000000000000
--- a/dev-python/sphinx/sphinx-4.1.2.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="https://www.sphinx-doc.org/
- https://github.com/sphinx-doc/sphinx"
-SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
-S=${WORKDIR}/${P^}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc latex"
-
-RDEPEND="
- <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/imagesize[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-htmlhelp-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-serializinghtml-1.1.5[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- latex? (
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-luatex
- app-text/dvipng
- )"
-BDEPEND="
- doc? (
- dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
- media-gfx/graphviz
- )
- test? (
- dev-python/html5lib[${PYTHON_USEDEP}]
- virtual/imagemagick-tools[jpeg,png,svg]
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-luatex
- app-text/dvipng
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.2.1-doc-link.patch"
- # https://github.com/sphinx-doc/sphinx/commit/1fd5f746539d3e02886032fae8d53af0c2f6ecdd
- "${FILESDIR}/${P}-py310.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # disable internet access
- sed -i -e 's:^intersphinx_mapping:disabled_&:' \
- doc/conf.py || die
-
- # remove unnecessary upper bounds
- sed -e '/Jinja2/s:,<3.0::' \
- -e '/MarkupSafe/s:<2.0::' \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # Generate the grammar. It will be caught by install somehow.
- # Note that the tests usually do it for us. However, I don't want
- # to trust USE=test really running all the tests, especially
- # with FEATURES=test-fail-continue.
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
- popd >/dev/null || die
-}
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
- local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
-
- local deselect=(
- # these tests require Internet access
- tests/test_build_latex.py::test_latex_images
- tests/test_build_linkcheck.py::test_defaults
- tests/test_build_linkcheck.py::test_defaults_json
- tests/test_build_linkcheck.py::test_anchors_ignored
- )
- [[ ${EPYTHON} == python3.10 ]] && deselect+=(
- tests/test_ext_autodoc.py::test_enum_class
- )
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- tests/test_build_linkcheck.py::test_connect_to_selfsigned_fails
- tests/test_ext_autodoc.py::test_autodoc_inherited_members_None
- tests/test_ext_autodoc.py::test_autodoc_typed_inherited_instance_variables
- tests/test_ext_autodoc.py::test_autodoc_typed_instance_variables
- tests/test_ext_autodoc.py::test_automethod_for_builtin
- tests/test_ext_autodoc.py::test_cython
- tests/test_ext_autodoc.py::test_partialfunction
- tests/test_ext_autodoc_autoclass.py::test_autodoc_process_bases
- tests/test_ext_autodoc_autoclass.py::test_show_inheritance_for_subclass_of_generic_type
- tests/test_ext_autodoc_autodata.py::test_autodata_type_comment
- tests/test_ext_autodoc_autofunction.py::test_builtin_function
- tests/test_ext_autodoc_autofunction.py::test_methoddescriptor
- tests/test_ext_autodoc_configs.py::test_autodoc_type_aliases
- tests/test_ext_autodoc_configs.py::test_autodoc_typehints_signature
- tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module
- tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module_skipped
- tests/test_pycode_parser.py::test_annotated_assignment
- )
-
- epytest ${deselect[@]/#/--deselect }
-}