summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-05-27 15:14:02 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-07 10:34:04 +0200
commitf0b2e0a356f7857be17ef12bfc22392ffc7de7d8 (patch)
tree47a1dc25bb7f1c3b52df4ed4b858859f5b0a4348 /dev-python
parentdev-python/whisper: update HOMEPAGE and upstream info in metadata.xml (diff)
downloadgentoo-f0b2e0a356f7857be17ef12bfc22392ffc7de7d8.tar.gz
gentoo-f0b2e0a356f7857be17ef12bfc22392ffc7de7d8.tar.bz2
gentoo-f0b2e0a356f7857be17ef12bfc22392ffc7de7d8.zip
dev-python/whisper: bump to 1.1.3, add tests, Python 3 support
Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8617
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/whisper/Manifest1
-rw-r--r--dev-python/whisper/whisper-1.1.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index e892f947b542..b5b626668c9f 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1,2 +1,3 @@
DIST whisper-0.9.13.tar.gz 14028 BLAKE2B 38c1d006c3b6334df8c18c7e5f695359912db225b72047c0549ba6ca786a1f8f2820a18957d8f0a9bdd07ffa723b9c12b3ddd501d88a65c55d3df6db241aa94e SHA512 b4b46bb7f31ecb766495f5f592fb2f9a754f5f38f83f071b533d4302b95808b9b4046bf7769bfa0d7713633344c7c693b57dd550b52acec4617257eba68634c1
DIST whisper-0.9.15.tar.gz 15655 BLAKE2B d2f8a1333312038fdec2ed990c4657255242da74d68fb07aa1099fce345d95c15ea98a28a2a3a582b7972c6b67df9f0e2ea2280b9ba9168d65638548d53b8555 SHA512 bdc9d299ed713a3fc6104938c347682562d5f17a7f3650d823f9814410dc934899b81bb2f42f52e9cc25313d8ed33f7b4def6d8945561d63f6237492bda2a5e6
+DIST whisper-1.1.3.tar.gz 37716 BLAKE2B e0cad5c7ef8ca885cae2060838669d80e8b2e28d1039dce45fec601257c866d202a73279d923aff39781f71d7c9bfdc19300c991e7a5956af337d5ff18a37ede SHA512 cd2a1bece58ea4cb3f5df6adbe1966e1408c92a55b21bf7298d4b30fdd51780e236707cae1414d6c363a046a36870a6ac230ec30abe565fde9fbf17efc9e7cab
diff --git a/dev-python/whisper/whisper-1.1.3.ebuild b/dev-python/whisper/whisper-1.1.3.ebuild
new file mode 100644
index 000000000000..d3df70da0981
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{3,} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}