summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-11-08 15:10:53 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-11-08 15:10:53 +0700
commitf1061ef6321b2f7943c88dcc7a8f73785c0bb8f7 (patch)
treed887afb41d3de7bde39a432f01431fa621ad69a5 /dev-python
parentsci-geosciences/gpxsee: clean old versions (diff)
downloadgentoo-f1061ef6321b2f7943c88dcc7a8f73785c0bb8f7.tar.gz
gentoo-f1061ef6321b2f7943c88dcc7a8f73785c0bb8f7.tar.bz2
gentoo-f1061ef6321b2f7943c88dcc7a8f73785c0bb8f7.zip
dev-python/bpython: bump to 0.22
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.22.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index fb515b9ea88b..2ee4a812dade 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1 +1,2 @@
DIST bpython-0.21.tar.gz 208206 BLAKE2B 22db7abe3786df337af50f6217fa8c6702871b50de41245797270e70622084a22b3d6615cfe634044599a532c5bc14677b01dc77042d228213eaae2cad11b623 SHA512 a0eea1b9c2329ce5665456e99703ef476faab38f880eb8a330a6536970888cfdaada9f0e377d3c1acd8b6c79eb0c562ada43e82bac9df4cce5878594c3399ddf
+DIST bpython-0.22.tar.gz 217214 BLAKE2B 9b9dbd639082b978134ad1ff68f9248c08e4e80c688978b05effa80410f96c58a524cfc1bd3c547f97458c7164672983e9cfc90d821919720442bd2d1d1a4293 SHA512 14f275c5ed9de08223020a6c70b466507236e84ee9c3dd60d51bb8b1908e943071f54acc68c611fbd64f28f283306a7ea2b6bde0b475fda528cb5e0cf9872b28
diff --git a/dev-python/bpython/bpython-0.22.ebuild b/dev-python/bpython/bpython-0.22.ebuild
new file mode 100644
index 000000000000..191c0fc1f59a
--- /dev/null
+++ b/dev-python/bpython/bpython-0.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.3.5[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ "
+
+DOCS=( AUTHORS.rst CHANGELOG.rst )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest