summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:13:58 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:13:58 -0400
commitf1b57cb8b2995eff632e8d9caee5d3082c9dfa32 (patch)
tree9535ce444777522318771ac6bcdc673fa1673e3f /dev-python
parentInitial commit. Required by weasyprint. (diff)
downloadgentoo-f1b57cb8b2995eff632e8d9caee5d3082c9dfa32.tar.gz
gentoo-f1b57cb8b2995eff632e8d9caee5d3082c9dfa32.tar.bz2
gentoo-f1b57cb8b2995eff632e8d9caee5d3082c9dfa32.zip
dev-python/pytest-isort: Initial commit
Required by weasyprint. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-isort/Manifest1
-rw-r--r--dev-python/pytest-isort/metadata.xml16
-rw-r--r--dev-python/pytest-isort/pytest-isort-0.1.0.ebuild26
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-isort/Manifest b/dev-python/pytest-isort/Manifest
new file mode 100644
index 000000000000..620919e8fb9d
--- /dev/null
+++ b/dev-python/pytest-isort/Manifest
@@ -0,0 +1 @@
+DIST pytest-isort-0.1.0.tar.gz 5502 SHA256 e92798127e21d22513c62070989f0fb3b712650e48a4db13e5b8e8034d367cfe SHA512 86c964b6a998a32c9c474dde0a9400c45da8b26f3e8dd6f4092baa4bf1978a7f67a384bd910ec824f85a8ab49b4ea30967e1e7f908a31619ee88391d3505440b WHIRLPOOL 2cf95b1586ee52ee0f8df44a4a9a6e1ae06fd75dcbc572eab1b7c773c4632f23f5f3e11347c32b9aa67258b433670205dd5102e29d2b6886e94452db9c9e931d
diff --git a/dev-python/pytest-isort/metadata.xml b/dev-python/pytest-isort/metadata.xml
new file mode 100644
index 000000000000..663b809a46e4
--- /dev/null
+++ b/dev-python/pytest-isort/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-isort</remote-id>
+ <remote-id type="github">moccu/pytest-isort</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild b/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
new file mode 100644
index 000000000000..d0c9bc036a4d
--- /dev/null
+++ b/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for isort"
+HOMEPAGE="https://github.com/moccu/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/isort-3.9.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cache-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"