summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-27 00:32:42 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-27 00:43:01 -0600
commitf22b045c438cf435e4efddc1735fada19eb1a730 (patch)
tree5eed2377dd72cd8fb35171d8899630dbbdc326af /dev-python
parentdev-python/python-saharaclient: bup (diff)
downloadgentoo-f22b045c438cf435e4efddc1735fada19eb1a730.tar.gz
gentoo-f22b045c438cf435e4efddc1735fada19eb1a730.tar.bz2
gentoo-f22b045c438cf435e4efddc1735fada19eb1a730.zip
dev-python/python-senlinclient: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-senlinclient/Manifest1
-rw-r--r--dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-senlinclient/Manifest b/dev-python/python-senlinclient/Manifest
index 4cfb494a25e2..16d791127e5d 100644
--- a/dev-python/python-senlinclient/Manifest
+++ b/dev-python/python-senlinclient/Manifest
@@ -1 +1,2 @@
DIST python-senlinclient-1.0.0.tar.gz 101396 SHA256 eb4fe96425cfc2c8137b97f2ab9071ebea1a2862b334ab1882513379fed12876 SHA512 3e98cc9a238250ca4069289343011d27d9bf6b35e0c8709bbf209b7774ff7b84151533104795fcc21403202cf6c834503685a9994d320a48aa690a854e1570f9 WHIRLPOOL 559b26f5be8ef0e99c63474f79b22e7baa05ca38b804c309fde4459668dbceba022175d8db156fc283af66bb87322ffe31e58cdd39c022d25f1af2e1ae00d497
+DIST python-senlinclient-1.2.0.tar.gz 107117 SHA256 5332f94f1dc533ce63e4b6c3649e6ec6304564f3b213eeb24ce602b73e979870 SHA512 1216e9511715a2cc5a703020a08ebb01bc24111150230f7ae8441ab750865c4cc07535f2b9d15ee8f7c93cc4f2ebd24473fb38b3946476063eff05c103d8ef6b WHIRLPOOL 7769f8d6a859b0a2ff4ffcc620f827ab49686ba3e1414a548c592d6af76ba5e898ac381d4ed584341c3c807b7ec104ef5b9ca806624921bc8c4b6a0882fda1c2
diff --git a/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild b/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild
new file mode 100644
index 000000000000..0d6ce6b43b44
--- /dev/null
+++ b/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Senlin API"
+HOMEPAGE="https://github.com/openstack/python-senlinclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.9.10[${PYTHON_USEDEP}]
+ !~dev-python/openstacksdk-0.9.11[${PYTHON_USEDEP}]
+ !~dev-python/openstacksdk-0.9.12[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-heatclient-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}