summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 15:33:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 15:35:31 +0100
commitf2616e201c12beba5301ba0538864a25839c7141 (patch)
tree8a51a40cf85bf70c61e6d2956550019ceca2688a /dev-python
parentdev-python/aws-sam-translator: Sync keywords to 1.55.0-r1 (diff)
downloadgentoo-f2616e201c12beba5301ba0538864a25839c7141.tar.gz
gentoo-f2616e201c12beba5301ba0538864a25839c7141.tar.bz2
gentoo-f2616e201c12beba5301ba0538864a25839c7141.zip
dev-python/cfn-lint: Remove Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.2.ebuild2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.4.ebuild4
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.5.ebuild54
3 files changed, 3 insertions, 57 deletions
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild
index 065d03e7ed78..06f14d0cbe77 100644
--- a/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild
+++ b/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild
index 0b3070eb0d84..d2f168651a4a 100644
--- a/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild
+++ b/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.5.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.5.ebuild
deleted file mode 100644
index 0b3070eb0d84..000000000000
--- a/dev-python/cfn-lint/cfn-lint-0.72.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="CloudFormation Linter"
-HOMEPAGE="
- https://github.com/aws-cloudformation/cfn-lint/
- https://pypi.org/project/cfn-lint/
-"
-SRC_URI="
- https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/aws-sam-translator-1.55.0[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
- dev-python/junit-xml[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO
- test/unit/module/test_template.py::TestTemplate::test_build_graph
- # requires git repo
- test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
- # Internet
- test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
- test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
- test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
-)
-
-src_prepare() {
- # unpin the deps
- sed -e 's:~=[0-9.]*::' -i setup.py || die
- distutils-r1_src_prepare
-}