summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 13:19:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 13:35:36 +0200
commitf6004774af9db846c9c6e8153eb91cb99a09c1a5 (patch)
tree053adf49f8efff7b97e1dc7eb85624fd1a6fb2fd /dev-python
parentdev-python/pytest-metadata: Enable py3.9 & py3.10 (diff)
downloadgentoo-f6004774af9db846c9c6e8153eb91cb99a09c1a5.tar.gz
gentoo-f6004774af9db846c9c6e8153eb91cb99a09c1a5.tar.bz2
gentoo-f6004774af9db846c9c6e8153eb91cb99a09c1a5.zip
dev-python/pyro: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyro/pyro-4.80.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/pyro/pyro-4.80.ebuild b/dev-python/pyro/pyro-4.80.ebuild
index 8a76e66ae186..1c2150e74eee 100644
--- a/dev-python/pyro/pyro-4.80.ebuild
+++ b/dev-python/pyro/pyro-4.80.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
MY_PN="Pyro4"
@@ -15,6 +13,7 @@ DESCRIPTION="Distributed object middleware for Python (RPC)"
HOMEPAGE="https://pypi.org/project/Pyro4/
https://github.com/irmen/Pyro4"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="4"
@@ -32,8 +31,6 @@ DEPEND="${RDEPEND}
>=dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
)"
-S="${WORKDIR}/${MY_P}"
-
python_prepare_all() {
# Disable tests requiring network connection.
rm tests/PyroTests/test_naming.py || die