summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-11-25 23:52:33 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-11-25 23:52:33 +0100
commitf8e5373a14690898e6c11e5ff464d99d9da86285 (patch)
tree63b47411a48950f8da5bf02802be35d06f62b122 /dev-python
parentapp-crypt/argon2: new ebuild. (diff)
downloadgentoo-f8e5373a14690898e6c11e5ff464d99d9da86285.tar.gz
gentoo-f8e5373a14690898e6c11e5ff464d99d9da86285.tar.bz2
gentoo-f8e5373a14690898e6c11e5ff464d99d9da86285.zip
dev-python/py2neo: version bump.
Gentoo-Bug: https://bugs.gentoo.org/600462 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/py2neo/Manifest1
-rw-r--r--dev-python/py2neo/py2neo-2.0.9.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/py2neo/Manifest b/dev-python/py2neo/Manifest
index c6f03d512a34..f8b2abfc5128 100644
--- a/dev-python/py2neo/Manifest
+++ b/dev-python/py2neo/Manifest
@@ -1 +1,2 @@
DIST py2neo-2.0.8.tar.gz 860564 SHA256 57b4a1c4aa800e03904b2adfd7c8ec467b072bae2d24baf150fd580916255f2e SHA512 77f18a86ccd16d0152b814fa0e10d7a5629ade5a76f027aa13c856a7d4ac7d51861e87c04a9f9012c87b533f202774c0c84d16b4c65435406114f70bb59a7e1b WHIRLPOOL e779abb6de768205076783adf0f7816cdcfefc77cb5d52162485c69bdeed6df2fd2bdd3f28539567c480d97ff3783e7711f9b6ddec9c193f5ea19a98aff7d799
+DIST py2neo-2.0.9.tar.gz 943617 SHA256 3e06fd82923725fe0f65622abd8d26fbe8403f489e07df16367da1e9bb53820d SHA512 cf0a0fe30e717c32f0a2effc6927e12c6e99173d9592ad549274dd983188f0f09418035b04429b99dac9ab80a8771c3c741a12983a85317eff924cec40f2fc59 WHIRLPOOL 764a96fe01d96553cf1bfe59fc9bbf3b05993cf6d0f2a953b5debdbcc4992ee7fd859d3843d99043030982e53b29c14c097eb3463ac5bc6277c3a06ac10176bb
diff --git a/dev-python/py2neo/py2neo-2.0.9.ebuild b/dev-python/py2neo/py2neo-2.0.9.ebuild
new file mode 100644
index 000000000000..fb3ac4c9d5d6
--- /dev/null
+++ b/dev-python/py2neo/py2neo-2.0.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A simple and pragmatic library which accesses the Neo4j graph database"
+HOMEPAGE="http://py2neo.org"
+SRC_URI="https://github.com/nigelsmall/py2neo/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_compile() {
+ # https://github.com/nigelsmall/py2neo/issues/380
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}