summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-02-26 22:21:13 -0800
committerZac Medico <zmedico@gentoo.org>2017-02-26 22:21:13 -0800
commitf96f6b25cf097814db43722325186def6cc35d7c (patch)
tree3f02c082b583db3a2e07f0e08fe98dce04d0f4be /dev-python
parentdev-python/warlock: PYTHON_COMPAT: add python3_6 (diff)
downloadgentoo-f96f6b25cf097814db43722325186def6cc35d7c.tar.gz
gentoo-f96f6b25cf097814db43722325186def6cc35d7c.tar.bz2
gentoo-f96f6b25cf097814db43722325186def6cc35d7c.zip
dev-python/jsonpatch: version bump to 1.15
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonpatch/Manifest1
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.15.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index b6674670f292..d291903f534b 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,2 +1,3 @@
DIST jsonpatch-1.13.tar.gz 15119 SHA256 9470656a08002e309632b59772b206ce0564c9a77b44c25f05f49dd2cad248d5 SHA512 23f0c92c2c8834d5e3129e9ba78ece7da2646dd60d5b0522b0f09d83e20057ef7517042e5ee8547804185d3ce23cff394c8fe78df93fad7999fae12cc5467a45 WHIRLPOOL 39a08103e5476a2ddb8fb120b61d6e99d80ff1bfe0a1b2949515d830299e99f5a41ca15b7e507b4700ca948687082ff1edce3c13ce5a161bb08fe6f57bffecbb
+DIST jsonpatch-1.15.tar.gz 15544 SHA256 ae23cd08b2f7246f8f2475363501e740c4ef93f08f2a3b7b9bcfac0cc37fceb1 SHA512 c5df880764b14a2fb60bb46e319bf006644ce1472d0413cf08ad151cf386e5be9fec197fd9efe0bfc3aa22dadf4078344c11211c1e8a3d5cc3ddcb998795dc91 WHIRLPOOL cacc064387db34183d7790bf1379daab37f104c6247888f4cee3108c43ef4a45cb589216df23b536f9c9e38ff94b52b4ca89b7f53bd37280f4d5b605f307ffa1
DIST jsonpatch-1.9.tar.gz 14275 SHA256 e997076450992aa7af2f4ae6c3e7767d390ddb6746979c74fd2092bb8fbdf5b2 SHA512 9f27def8519677dbc6d45287b6938ccfb9179f7a315871adeb7198e1568876a391625c060c7901b7acd51af0ed10427a61d54d899719ef1a073b2e93591904ed WHIRLPOOL a7ee28b9cefa8ddebb060867b260b388cd44ce96f0f2a76698091f55d41be44cd690b32d26b1363218c474fc1dd9cfe8eed3c0d939e9e9d8d4c2214e1b08786b
diff --git a/dev-python/jsonpatch/jsonpatch-1.15.ebuild b/dev-python/jsonpatch/jsonpatch-1.15.ebuild
new file mode 100644
index 000000000000..841ba4ab3d14
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+ http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}