summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-07-30 19:34:47 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 19:43:00 +0200
commitf99ae4abdc0299534dad347d391cfd3f7ba68496 (patch)
tree8b00a9c207451fccaa28f35ee2c82695a3bd93a9 /dev-python
parentdev-python/pytest: Add missing DEPEND on dev-python/setuptools_scm (diff)
downloadgentoo-f99ae4abdc0299534dad347d391cfd3f7ba68496.tar.gz
gentoo-f99ae4abdc0299534dad347d391cfd3f7ba68496.tar.bz2
gentoo-f99ae4abdc0299534dad347d391cfd3f7ba68496.zip
dev-python/w3lib: Version bump to 1.17.0
Bug: https://bugs.gentoo.org/show_bug.cgi?id=626610 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/w3lib/Manifest1
-rw-r--r--dev-python/w3lib/w3lib-1.17.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/w3lib/Manifest b/dev-python/w3lib/Manifest
index c0ce7c129b05..ca54582bbcc9 100644
--- a/dev-python/w3lib/Manifest
+++ b/dev-python/w3lib/Manifest
@@ -1 +1,2 @@
DIST w3lib-1.13.0.tar.gz 36757 SHA256 72739cb480413a1d2cf176942986a2b9113411166ac81f2551e5f5eecc383a84 SHA512 813a709ac20d5b7a3231a2f2f2336de574f1aa9eaa005bc60eb0e79d56a71f8ca88c6b793692eb26950c2310a23d27963b4bf36f8857bf6ecee9bda50fecee42 WHIRLPOOL 33d497e60c3f2c635d81ea36e00dcd8d6867c69ed4af5d5a95ba7df355dd1aeec6bedd1f5abfd86d2da79d9e70b142dc88c9dedaf76dd28390a831094225e055
+DIST w3lib-1.17.0.tar.gz 30357 SHA256 d8c654827fcf92ba4d7111f8588d2eff8653c5580c27ca61b1bc7805c080506f SHA512 a131e1671e27d34c77ff62ce17aa1d28461d12b66e1fef4f4410d061f2a75ee4cdbbb447eea16c265ca6e4f1da2e72c8cf30f87fe1a92a8f3f70df036b4b2c96 WHIRLPOOL bfd67603a0089679c9e454e950e98ffe85fd51862a64b8b5bba6c40eb446e1a5735144a7ddaf613f2ef0fe9baf6004e1157b8198034f75cd9314dc00f6adaa39
diff --git a/dev-python/w3lib/w3lib-1.17.0.ebuild b/dev-python/w3lib/w3lib-1.17.0.ebuild
new file mode 100644
index 000000000000..a289b4082610
--- /dev/null
+++ b/dev-python/w3lib/w3lib-1.17.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library of web-related functions"
+HOMEPAGE="https://github.com/scrapy/w3lib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.4.1[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test || die
+}