summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-10-11 17:28:13 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-10-11 17:29:38 +0300
commitfb157138b11030afff7cde5b2a5636cb0f13d09d (patch)
tree3ca6a5be5ba0c4450782ceab3873306109fba1ba /dev-python
parentmedia-video/pipewire: bump to v0.3.13 (diff)
downloadgentoo-fb157138b11030afff7cde5b2a5636cb0f13d09d.tar.gz
gentoo-fb157138b11030afff7cde5b2a5636cb0f13d09d.tar.bz2
gentoo-fb157138b11030afff7cde5b2a5636cb0f13d09d.zip
dev-python/matplotlib-python2: remove last-rited pkg.
Closes: https://bugs.gentoo.org/730246 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib-python2/Manifest1
-rw-r--r--dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch18
-rw-r--r--dev-python/matplotlib-python2/matplotlib-python2-2.2.5-r2.ebuild208
-rw-r--r--dev-python/matplotlib-python2/metadata.xml26
4 files changed, 0 insertions, 253 deletions
diff --git a/dev-python/matplotlib-python2/Manifest b/dev-python/matplotlib-python2/Manifest
deleted file mode 100644
index e15d4fa58675..000000000000
--- a/dev-python/matplotlib-python2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST matplotlib-2.2.5.tar.gz 36678633 BLAKE2B fb3084a2d34a920413c44a23a956ffdcf7a31d521e2d1df50a68c9f17882cb87deebb403ec47154284593b39df24dad72e6352e1427091f795058db11f1d3a1b SHA512 f4771dca4b3c936e0d47f42630759207ccfe11586b3efadb401144b014a600914a6521af4fbe060fa80fd74132c92f1d3b37cac4fea9999ca90300c1dec8391b
diff --git a/dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch b/dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch
deleted file mode 100644
index b6a01b097a61..000000000000
--- a/dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/doc/conf.py b/doc/conf.py
-index 017ce210e..5a397082b 100644
---- a/doc/conf.py
-+++ b/doc/conf.py
-@@ -170,10 +170,10 @@ source_encoding = "utf-8"
- master_doc = 'contents'
-
- # General substitutions.
--from matplotlib.compat.subprocess import check_output
--SHA = check_output(['git', 'describe', '--dirty']).decode('utf-8').strip()
-+#from matplotlib.compat.subprocess import check_output
-+#SHA = check_output(['git', 'describe', '--dirty']).decode('utf-8').strip()
-
--html_context = {'sha': SHA}
-+#html_context = {'sha': SHA}
-
- project = 'Matplotlib'
- copyright = ('2002 - 2012 John Hunter, Darren Dale, Eric Firing, '
diff --git a/dev-python/matplotlib-python2/matplotlib-python2-2.2.5-r2.ebuild b/dev-python/matplotlib-python2/matplotlib-python2-2.2.5-r2.ebuild
deleted file mode 100644
index 4d925d88348f..000000000000
--- a/dev-python/matplotlib-python2/matplotlib-python2-2.2.5-r2.ebuild
+++ /dev/null
@@ -1,208 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
-
-MY_PN=${PN/-python2}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Pure python plotting library with matlab like syntax (py2 version)"
-HOMEPAGE="https://matplotlib.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-IUSE="cairo excel gtk3 latex test tk wxwidgets"
-REQUIRED_USE="test? ( cairo gtk3 latex tk wxwidgets )"
-
-RESTRICT="!test? ( test )"
-
-# #456704 -- a lot of py2-only deps
-COMMON_DEPEND="
- dev-python/functools32[${PYTHON_USEDEP}]
- dev-python/subprocess32[${PYTHON_USEDEP}]
- dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
- dev-python/cycler[${PYTHON_USEDEP}]
- || (
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
- )
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.10[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- >=media-libs/qhull-2013
- >=dev-python/kiwisolver-1.0.0[${PYTHON_USEDEP}]
- cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- dev-python/versioneer[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${COMMON_DEPEND}
- !<dev-python/matplotlib-3
- >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
- excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
- gtk3? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]
- )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- )"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pkg_setup() {
- unset DISPLAY # bug #278524
-}
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
-# Generates test failures, but fedora does it
-# local PATCHES=(
-# "${FILESDIR}"/${P}-unbundle-pycxx.patch
-# "${FILESDIR}"/${P}-unbundle-agg.patch
-# )
-# rm -r agg24 CXX || die
-# rm -r agg24 || die
-
-# cat > lib/${PN}/externals/six.py <<-EOF
-# from __future__ import absolute_import
-# from six import *
-# EOF
-
- local PATCHES=(
- "${FILESDIR}"/${MY_PN}-2.2.4-doc-fix.patch
- )
-
- sed \
- -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- hprefixify setupext.py
-
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
- append-cppflags -DNDEBUG # or get old trying to do triangulation
- tc-export PKG_CONFIG
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
- [directories]
- basedirlist = ${EPREFIX}/usr
- [provide_packages]
- pytz = False
- dateutil = False
- [packages]
- tests = $(usex test True False)
- [gui_support]
- agg = True
- pyside = False
- pysideagg = False
- qt4 = False
- qt4agg = False
- qt5 = False
- qt5agg = False
- $(use_setup cairo)
- $(use_setup gtk3)
- $(use_setup tk)
- EOF
-
- if use gtk3 && use cairo; then
- echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
- else
- echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
- fi
-
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- gtk = False
- gtkagg = False
- $(use_setup wxwidgets wx)
- EOF
-}
-
-wrap_setup() {
- local MAKEOPTS=-j1
- local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
- unset DISPLAY
- "$@"
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-
- # mpl_toolkits namespace
- python_moduleinto mpl_toolkits
- python_domodule lib/mpl_toolkits/__init__.py
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/matplotlib-python2/metadata.xml b/dev-python/matplotlib-python2/metadata.xml
deleted file mode 100644
index f024fad13338..000000000000
--- a/dev-python/matplotlib-python2/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- matplotlib is an interactive library for plotting and doing basic
- data analysis in python with a syntax similar to matlab. It provides a
- variety of backends and hard copy formats for almost ready
- publication plots.
- </longdescription>
- <use>
- <flag name="excel">Pull <pkg>dev-python/xlwt</pkg> for the exceltools toolkit</flag>
- <flag name="gtk3">Enable <pkg>x11-libs/gtk+</pkg>:3 support</flag>
- </use>
- <upstream>
- <remote-id type="pypi">matplotlib</remote-id>
- <remote-id type="sourceforge">matplotlib</remote-id>
- </upstream>
-</pkgmetadata>