summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-07 02:23:35 -0400
committerMichael Palimaka <kensington@gentoo.org>2017-07-08 12:36:59 +1000
commitfba2e61745acf4c20d1851ce6dac3cbe78443973 (patch)
treef42d684cb3e0d740e8a1c4b2073d380819e21930 /dev-python
parentapp-pda/libplist: remove 1.12 (diff)
downloadgentoo-fba2e61745acf4c20d1851ce6dac3cbe78443973.tar.gz
gentoo-fba2e61745acf4c20d1851ce6dac3cbe78443973.tar.bz2
gentoo-fba2e61745acf4c20d1851ce6dac3cbe78443973.zip
dev-python/shiboken: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=619332 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch20
-rw-r--r--dev-python/shiboken/shiboken-1.2.2.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch b/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch
new file mode 100644
index 000000000000..65734232472c
--- /dev/null
+++ b/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch
@@ -0,0 +1,20 @@
+Bug: https://bugs.gentoo.org/619332
+PR: https://github.com/pyside/Shiboken/pull/84
+
+--- a/tests/libsample/simplefile.cpp
++++ b/tests/libsample/simplefile.cpp
+@@ -90,13 +90,13 @@ bool
+ SimpleFile::exists() const
+ {
+ std::ifstream ifile(p->m_filename);
+- return ifile;
++ return static_cast<bool>(ifile);
+ }
+
+ bool
+ SimpleFile::exists(const char* filename)
+ {
+ std::ifstream ifile(filename);
+- return ifile;
++ return static_cast<bool>(ifile);
+ }
diff --git a/dev-python/shiboken/shiboken-1.2.2.ebuild b/dev-python/shiboken/shiboken-1.2.2.ebuild
index 89119cb728f2..65d6d0be4d16 100644
--- a/dev-python/shiboken/shiboken-1.2.2.ebuild
+++ b/dev-python/shiboken/shiboken-1.2.2.ebuild
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog )
PATCHES=(
"${FILESDIR}/${PV}-Fix-tests-with-Python-3.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
)
src_prepare() {