summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-16 10:41:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-16 11:00:15 -0500
commitfc07c10b2d8e5a6e1bf4b499d2cffe615594408c (patch)
tree07fc5db10c390ce570816828bfe30db9fe1e1dc1 /dev-python
parentdev-python/betamax: add py37 support (diff)
downloadgentoo-fc07c10b2d8e5a6e1bf4b499d2cffe615594408c.tar.gz
gentoo-fc07c10b2d8e5a6e1bf4b499d2cffe615594408c.tar.bz2
gentoo-fc07c10b2d8e5a6e1bf4b499d2cffe615594408c.zip
dev-python/requests-toolbelt: 0.9.1 bump and py37 support
Bug: https://bugs.gentoo.org/685330 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-toolbelt/Manifest1
-rw-r--r--dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/requests-toolbelt/Manifest b/dev-python/requests-toolbelt/Manifest
index 38e0d6c28e43..6a8f65f6617e 100644
--- a/dev-python/requests-toolbelt/Manifest
+++ b/dev-python/requests-toolbelt/Manifest
@@ -2,3 +2,4 @@ DIST requests-toolbelt-0.5.1.tar.gz 187981 BLAKE2B 1e3cfafd8e0b8625dc92ff40bf88d
DIST requests-toolbelt-0.7.0.tar.gz 194062 BLAKE2B ea7120e58ea23dbe1d17bc2f8c346ec00bd00d62a4c8fdefa1490b9b3ed62a0dcf45ce60b071fcbc7e510d943ec4f10a7031525bd24f5fb02749125cbccc9f0b SHA512 77f11d12643d7cacf0c5dab5c5490359fc6f11c038d56d6ae27939394c5788622edb230d38d2202192eec6a7b1229feeb5669cd6a33c78f6891699d017e8205e
DIST requests-toolbelt-0.7.1.tar.gz 194670 BLAKE2B 3f8b5950d3a87f519f40e2d21bce13ba2d3ed205b5d7f4fa0872339df391e5477f262b104697b264a75783d686eb44231ff2943bfe56f13695d63869227c48c5 SHA512 2559db13054c4d9b7c459603809a16d8d9a9c1a348369e1bc68e557bae10c41291286112e3b4a71e83b42203d40fa5cbc8441028693eeb986162d212a65f68ac
DIST requests-toolbelt-0.8.0.tar.gz 196129 BLAKE2B 435059ff2879c44a274641c49adae9986c761fcabe567826454d3f055db7e3e5c95905f1d178dcb37e2173bf856a9fb168a856c1301026e8c5d0de6cafb4be51 SHA512 71a4ed8961b742cb1b5b0deec7f9052a2a177d2ed6e4f13ebe22b56b7f1b6b1bad2736f1640c8b41398b082eddc1c1205f0c446602d979d5bf370fb0e10ecc88
+DIST requests-toolbelt-0.9.1.tar.gz 207286 BLAKE2B 6123677a9abafebddf7dffde2150b2426b5132ebe0c330ff891322ecc3d69232a5b15a0c66e3e1fb4832dc04f5a636a939613fba041e499e9fbca9814f548c7e SHA512 12229928df5df71cb57bc65ef453dc0e4a2bbe190c1579811b2c2823673bd81aeba856b00000fa20b253d0f0fa4fff55ea1e750794ca3785f71c376b1df7fd93
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
new file mode 100644
index 000000000000..d7c16d63b6c0
--- /dev/null
+++ b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A utility belt for advanced users of python-requests"
+HOMEPAGE="https://toolbelt.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="<dev-python/requests-3.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/betamax[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst HISTORY.rst README.rst )
+PATCHES=(
+ "${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
+)
+
+# Known python2.7 test failures do to upstream
+# not testing with newer requests versions
+# bug: https://bugs.gentoo.org/635824
+# https://github.com/requests/toolbelt/issues/213
+RESTRICT=test
+
+python_test() {
+ py.test -v || die "Tests failed with ${EPYTHON}"
+}