summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-09-29 10:36:11 -0400
committerMike Gilbert <floppym@gentoo.org>2020-09-29 10:36:11 -0400
commitfe13784be44e5167f67315bf280690004aae885e (patch)
tree8dc3a2c7b23ffbbe5347964276eab3714ba2898c /dev-python
parentsci-libs/brial: new version 1.2.9. (diff)
downloadgentoo-fe13784be44e5167f67315bf280690004aae885e.tar.gz
gentoo-fe13784be44e5167f67315bf280690004aae885e.tar.bz2
gentoo-fe13784be44e5167f67315bf280690004aae885e.zip
dev-python/setuptools: set DISTUTILS_USE_SETUPTOOLS=manual
The install QA check correctly detects that setuptools depends on itself at runtime, but we don't want to add a self-referential dependency to RDEPEND. Closes: https://bugs.gentoo.org/745417 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/setuptools-46.4.0-r3.ebuild3
-rw-r--r--dev-python/setuptools/setuptools-50.3.0.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/setuptools/setuptools-46.4.0-r3.ebuild b/dev-python/setuptools/setuptools-46.4.0-r3.ebuild
index f42864c53f39..9819bcdb50ec 100644
--- a/dev-python/setuptools/setuptools-46.4.0-r3.ebuild
+++ b/dev-python/setuptools/setuptools-46.4.0-r3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=no
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="xml(+)"
diff --git a/dev-python/setuptools/setuptools-50.3.0.ebuild b/dev-python/setuptools/setuptools-50.3.0.ebuild
index 0d8d2e8bfb98..ccd3f2338abb 100644
--- a/dev-python/setuptools/setuptools-50.3.0.ebuild
+++ b/dev-python/setuptools/setuptools-50.3.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=no
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="xml(+)"