summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-11 02:13:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-11 02:49:07 +0200
commitff9b808a5b353221275fab370a6c7d5f7b7c6ca8 (patch)
tree21ea539c9f9d53ae613e8755c52d95baff7d5026 /dev-python
parentapp-text/xournalpp: No stripping (think of the kids) (diff)
downloadgentoo-ff9b808a5b353221275fab370a6c7d5f7b7c6ca8.tar.gz
gentoo-ff9b808a5b353221275fab370a6c7d5f7b7c6ca8.tar.bz2
gentoo-ff9b808a5b353221275fab370a6c7d5f7b7c6ca8.zip
dev-python/joblib: bump to 0.17.0, add Python 3.9 support
Also remove doc altogether since it is already masked. Closes: https://bugs.gentoo.org/700164 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-0.17.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index bcaca744dab1..e1489fb1b9f8 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1,3 +1,4 @@
DIST joblib-0.14.1.tar.gz 338930 BLAKE2B 6b84c43be8b8d32f28a3dbc3e6f4ce15574cf20571805501972d162d4b076c1fe144a9790b8132821f0acd439c8859873038813c7bdd4163d0535eca36a1a8fa SHA512 079eb4321ed95c8f05399abca2a1c46ecb7c28fe9a3a50b6eb106a2bd2f3566fb25bca59022fafbfcee5069f078921421d799eeb29a796f8f98881491cf9be08
DIST joblib-0.15.1.tar.gz 342550 BLAKE2B c8ccf0b6d2e229a780939d9c4f39265bd18b5a452d014056001072b7daf7e46a5961c6d80f768c30ba7463aa36c5ec09959bb1e891028bf6f7862a9a265079aa SHA512 a0b0bde5b034af3eee0bce2875199fc9ac232a34a49c14daf6fbddd9bf3ad8fa0d77192827b7531704b81db7bdfbaf76c4755b8fc1035eaf73b2e08f9e6d8828
DIST joblib-0.16.0.tar.gz 345002 BLAKE2B 0336fcbe95204141a0b04dfbf8949ba509792402eefbb86b3dc02375e7e3eb5c76d548d4ad01238307c0334ce4299fd9e763765d92722819894ea26ab6144032 SHA512 9f1f2e7f2e293e1c53e9752907f4ba25d52a5c4895eebfa423c8e3bc64146ab20a490e1db0cfa39596c9bbc47ea1cc491b0576bf8da9a1f68b58e91ba09ead34
+DIST joblib-0.17.0.tar.gz 345984 BLAKE2B 4f4cb83037fc02ce9ea17e7dc5d284235b847eeb90bf1a877c4168aabd9ad4dd762e45a6485806efc759cdfcb98e6ee70e6d9a498cd7645b1d6b0051a9f9ba2e SHA512 73c42a9f5949478a4a03b97ec31549cabca2ebc968d2c869632696b671c175dc85ae7aa8ac92905f13f830083b2305b56df1552f1d70fa7fe51945ae7286840a
diff --git a/dev-python/joblib/joblib-0.17.0.ebuild b/dev-python/joblib/joblib-0.17.0.ebuild
new file mode 100644
index 000000000000..cbff1fbeb9f5
--- /dev/null
+++ b/dev-python/joblib/joblib-0.17.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="https://joblib.readthedocs.io/en/latest/
+ https://github.com/joblib/joblib"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/loky[${PYTHON_USEDEP}]
+"
+# joblib is imported by setup.py so we need ${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unbundle
+ rm -r joblib/externals || die
+ sed -e "s:'joblib.externals[^']*',\?::g" -i setup.py || die
+ find -name '*.py' -exec \
+ sed -e 's:\(joblib\)\?\.externals\.::' \
+ -e 's:from \.externals ::' \
+ -i {} + || die
+
+ # https://github.com/joblib/joblib/issues/1115
+ sed -e 's:test_parallel_call_cached_function_defined_in_jupyter:_&:' \
+ -i joblib/test/test_memory.py || die
+
+ # tries to fetch from the internet
+ rm examples/compressors_comparison.py \
+ examples/parallel/distributed_backend_simple.py || die
+
+ distutils-r1_python_prepare_all
+}