summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-09-13 15:02:13 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-11-06 12:23:48 +0100
commitffed15e1cc892d2479583aff9414388a71bea040 (patch)
tree7cb9771d349d71b08177e85882f7e6a992e124b2 /dev-python
parentdev-python/flask-mongoengine: version bump (diff)
downloadgentoo-ffed15e1cc892d2479583aff9414388a71bea040.tar.gz
gentoo-ffed15e1cc892d2479583aff9414388a71bea040.tar.bz2
gentoo-ffed15e1cc892d2479583aff9414388a71bea040.zip
dev-python/flask-security: rev-bump for EAPI 6 bump and py-3.5 support
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask-security/flask-security-1.7.5-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/flask-security/flask-security-1.7.5-r1.ebuild b/dev-python/flask-security/flask-security-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..09b5e6b22ed8
--- /dev/null
+++ b/dev-python/flask-security/flask-security-1.7.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Security"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="http://pythonhosted.org/Flask-Security/ https://pypi.python.org/pypi/Flask-Security"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests are foobar
+RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.17[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.8[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/flask-peewee[${PYTHON_USEDEP}]' 'python2*')
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}