summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-11 01:14:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 14:03:13 +0100
commit478e273889d822398fe7e36860fbddd04729ec04 (patch)
tree4e3e58325dac890c15de6b1c9bda009bbbca2594 /dev-qt/qtbluetooth
parentdev-qt/qtdeclarative: Fix build with GCC-11 (diff)
downloadgentoo-478e273889d822398fe7e36860fbddd04729ec04.tar.gz
gentoo-478e273889d822398fe7e36860fbddd04729ec04.tar.bz2
gentoo-478e273889d822398fe7e36860fbddd04729ec04.zip
dev-qt/qtbluetooth: Fix build with GCC-11
Bug: https://bugs.gentoo.org/752012 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtbluetooth')
-rw-r--r--dev-qt/qtbluetooth/files/qtbluetooth-5.15.2-gcc11.patch19
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild3
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/files/qtbluetooth-5.15.2-gcc11.patch b/dev-qt/qtbluetooth/files/qtbluetooth-5.15.2-gcc11.patch
new file mode 100644
index 000000000000..7c27730574b6
--- /dev/null
+++ b/dev-qt/qtbluetooth/files/qtbluetooth-5.15.2-gcc11.patch
@@ -0,0 +1,19 @@
+From 0ae88b90f857bfcc2d0ea33d16753d8eed5db9e1 Mon Sep 17 00:00:00 2001
+From: Jeff Law <law@redhat.com>
+Date: Oct 16 2020 20:08:46 +0000
+Subject: Add missing #include for gcc-11
+
+
+diff --git a/src/bluetooth/lecmaccalculator.cpp b/src/bluetooth/lecmaccalculator.cpp
+index b150466..507603c 100644
+--- a/src/bluetooth/lecmaccalculator.cpp
++++ b/src/bluetooth/lecmaccalculator.cpp
+@@ -38,6 +38,8 @@
+ ****************************************************************************/
+ #include "lecmaccalculator_p.h"
+
++#include <limits>
++
+ #include "bluez/bluez_data_p.h"
+
+ #include <QtCore/qbytearray.h>
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild
index 86342f95e592..f4571c977b8d 100644
--- a/dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
QT5_MODULE="qtconnectivity"
inherit qt5-build
@@ -24,6 +25,8 @@ DEPEND="${RDEPEND}
~dev-qt/qtnetwork-${PV}
"
+PATCHES=( "${FILESDIR}/${P}-gcc11.patch" ) # bug 752012
+
src_prepare() {
sed -i -e 's/nfc//' src/src.pro || die