summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-05 22:02:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-05 23:09:43 +0100
commitf0fd0fa275bf9552eb857ed38a80ba7589bd7ef2 (patch)
tree31519f5801a38b27b715ad8ecf93b45b538ef326 /dev-qt/qtconcurrent/qtconcurrent-5.11.3.ebuild
parentnet-wireless/wpa_supplicant: bump bug #672568 (diff)
downloadgentoo-f0fd0fa275bf9552eb857ed38a80ba7589bd7ef2.tar.gz
gentoo-f0fd0fa275bf9552eb857ed38a80ba7589bd7ef2.tar.bz2
gentoo-f0fd0fa275bf9552eb857ed38a80ba7589bd7ef2.zip
dev-qt: Add Qt 5.11.3
Bug: https://bugs.gentoo.org/670864 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.11.3.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.11.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.11.3.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.11.3.ebuild
new file mode 100644
index 000000000000..098a3a793986
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.11.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)