summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-20 21:35:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-20 21:42:06 +0200
commita3fadab0b087d57bc91eee9b9b539d03fc26bbda (patch)
treeec049592023a30c3b0043e5a006fd424941d44fc /dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
parentdev-qt/qtcharts: 5.15.4 version bump (diff)
downloadgentoo-a3fadab0b087d57bc91eee9b9b539d03fc26bbda.tar.gz
gentoo-a3fadab0b087d57bc91eee9b9b539d03fc26bbda.tar.bz2
gentoo-a3fadab0b087d57bc91eee9b9b539d03fc26bbda.zip
dev-qt/qtconcurrent: 5.15.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
new file mode 100644
index 000000000000..e8ed5dd37b26
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)