summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-13 18:50:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-13 18:50:45 +0200
commitf8b68cbe7c388bbfcf5134eefbca162c914f57dc (patch)
treeeb3ee941eca011b9f62e13971cd04e97b59ece99 /dev-qt/qtconcurrent/qtconcurrent-5.9.6.ebuild
parentmedia-libs/mesa: Support unconditional enabling of drivers (diff)
downloadgentoo-f8b68cbe7c388bbfcf5134eefbca162c914f57dc.tar.gz
gentoo-f8b68cbe7c388bbfcf5134eefbca162c914f57dc.tar.bz2
gentoo-f8b68cbe7c388bbfcf5134eefbca162c914f57dc.zip
dev-qt: Add Qt 5.9.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.9.6.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.9.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.9.6.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.9.6.ebuild
new file mode 100644
index 000000000000..75e304af27a0
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.9.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)