summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-23 03:00:47 +0100
committerSam James <sam@gentoo.org>2021-08-23 03:01:04 +0100
commite9d13c50ef08300d32a2f463cb69ece1fdaae838 (patch)
tree955b8912dd663dcecb03d02181421dc24d1d2e2d /dev-qt/qtconcurrent
parentmedia-plugins/kodi-pvr-hts: 8.4.0 version bump (diff)
downloadgentoo-e9d13c50ef08300d32a2f463cb69ece1fdaae838.tar.gz
gentoo-e9d13c50ef08300d32a2f463cb69ece1fdaae838.tar.bz2
gentoo-e9d13c50ef08300d32a2f463cb69ece1fdaae838.zip
dev-qt/qtconcurrent: revbump for GCC 11 fix, with additional patch
Closes: https://bugs.gentoo.org/764977 Closes: https://bugs.gentoo.org/806797 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt/qtconcurrent')
-rw-r--r--dev-qt/qtconcurrent/files/qtconcurrent-5.15.2-gcc11.patch45
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild30
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/files/qtconcurrent-5.15.2-gcc11.patch b/dev-qt/qtconcurrent/files/qtconcurrent-5.15.2-gcc11.patch
new file mode 100644
index 000000000000..b27ac767b064
--- /dev/null
+++ b/dev-qt/qtconcurrent/files/qtconcurrent-5.15.2-gcc11.patch
@@ -0,0 +1,45 @@
+https://bugs.gentoo.org/764977
+https://invent.kde.org/qt/qt/qtbase/-/commit/c9543da6998b0827fb75ffe22327c99e2da7d364
+
+From c9543da6998b0827fb75ffe22327c99e2da7d364 Mon Sep 17 00:00:00 2001
+From: Sona Kurazyan <sona.kurazyan@qt.io>
+Date: Wed, 17 Mar 2021 16:04:00 +0100
+Subject: [PATCH] Remove the unnecessary template parameter from the class
+ specialization
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This seems to cause errors when compiling with gcc-11. Although this is
+most likely a compiler bug, specifiying the template parameter type in
+this case isn't necessary.
+
+Fixes: QTBUG-91909
+Fixes: QTBUG-90568
+Change-Id: Ib231257ccb2e16cc533f23ca5840d31e26a66d53
+Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
+(cherry picked from commit 659f7a06e91c04b239e3f4c0bcfccbe3581af1c3)
+Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
+(cherry picked from commit 049e14870c13235cd066758f29c42dc96c1ccdf8)
+---
+ src/concurrent/qtconcurrentthreadengine.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/concurrent/qtconcurrentthreadengine.h b/src/concurrent/qtconcurrentthreadengine.h
+index af413707e4..a4c8548cc4 100644
+--- a/src/concurrent/qtconcurrentthreadengine.h
++++ b/src/concurrent/qtconcurrentthreadengine.h
+@@ -247,8 +247,8 @@ template <>
+ class ThreadEngineStarter<void> : public ThreadEngineStarterBase<void>
+ {
+ public:
+- ThreadEngineStarter<void>(ThreadEngine<void> *_threadEngine)
+- :ThreadEngineStarterBase<void>(_threadEngine) {}
++ ThreadEngineStarter(ThreadEngine<void> *_threadEngine)
++ : ThreadEngineStarterBase<void>(_threadEngine) {}
+
+ void startBlocking()
+ {
+--
+GitLab
+
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..f0ecb6cd1f63
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}:5=
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)
+
+PATCHES=(
+ "${WORKDIR}"/qtbase-${PV}-gcc11.patch # bug 752012
+ "${FILESDIR}"/${P}-gcc11.patch # bug #764977
+)