summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qtgraphicaleffects
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qtgraphicaleffects')
-rw-r--r--dev-qt/qtgraphicaleffects/Manifest1
-rw-r--r--dev-qt/qtgraphicaleffects/metadata.xml9
-rw-r--r--dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.4.2.ebuild28
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-qt/qtgraphicaleffects/Manifest b/dev-qt/qtgraphicaleffects/Manifest
new file mode 100644
index 000000000000..ce122fb41f16
--- /dev/null
+++ b/dev-qt/qtgraphicaleffects/Manifest
@@ -0,0 +1 @@
+DIST qtgraphicaleffects-opensource-src-5.4.2.tar.xz 14324140 SHA256 ba8f477be1b0675ce36f48530db050d2922b2a0d6ff80c46559245a94aede80a SHA512 205896a2551a2be99b015c4254ec5195f97ff99d266e377caaffe02033d5c0aa9d7509b781f5316074ebe5e2d8e768b90db81d19a2233f98c887c57a25046c38 WHIRLPOOL 4424a57f760cc8d7bbf71b890bf3eea50b01eb2f4a1b36e88c945a47adb05a6a7badca0066552f523c4807dc7ee40ea70dd5f79cc33d45a4a5f3d334152f150d
diff --git a/dev-qt/qtgraphicaleffects/metadata.xml b/dev-qt/qtgraphicaleffects/metadata.xml
new file mode 100644
index 000000000000..afb3b434585b
--- /dev/null
+++ b/dev-qt/qtgraphicaleffects/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.4.2.ebuild b/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.4.2.ebuild
new file mode 100644
index 000000000000..8a680ca8ed28
--- /dev/null
+++ b/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt5-build virtualx
+
+DESCRIPTION="Set of QML types for adding visual effects to user interfaces"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtcore-${PV}:5
+ >=dev-qt/qtdeclarative-${PV}:5
+ >=dev-qt/qtxmlpatterns-${PV}:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtgui-${PV}:5 )
+"
+
+src_test() {
+ local VIRTUALX_COMMAND="qt5-build_src_test"
+ virtualmake
+}