summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-18 13:57:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-18 13:58:29 +0100
commit14f33668f77134e9d2a4121bcbab3bdd8a15d303 (patch)
tree0908182155d3a0b97ffcd46e57c931b13de8ecab /dev-qt/qtlocation/qtlocation-5.14.0.ebuild
parentmedia-gfx/digikam: 6.4.0 version bump (diff)
downloadgentoo-14f33668f77134e9d2a4121bcbab3bdd8a15d303.tar.gz
gentoo-14f33668f77134e9d2a4121bcbab3bdd8a15d303.tar.bz2
gentoo-14f33668f77134e9d2a4121bcbab3bdd8a15d303.zip
dev-qt: Add Qt 5.14.0
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-5.14.0.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-5.14.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.14.0.ebuild b/dev-qt/qtlocation/qtlocation-5.14.0.ebuild
new file mode 100644
index 000000000000..ff48cdc6401b
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.14.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}