summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-10-08 12:37:36 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-10-08 12:46:26 +1100
commit73b3a139a33eee77302d943a4e7a7949ef5535c5 (patch)
treeb00d89573adcf67193287c6ee59644252bc62749 /dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.2.ebuild
parentqt5-build.eclass: don't add a test dependency for dev-qt/qtwebkit (diff)
downloadgentoo-73b3a139a33eee77302d943a4e7a7949ef5535c5.tar.gz
gentoo-73b3a139a33eee77302d943a4e7a7949ef5535c5.tar.bz2
gentoo-73b3a139a33eee77302d943a4e7a7949ef5535c5.zip
dev-qt: version bump 5.9.2
Bug: https://bugs.gentoo.org/625258 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.2.ebuild')
-rw-r--r--dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.2.ebuild b/dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.2.ebuild
new file mode 100644
index 000000000000..af1973c274ad
--- /dev/null
+++ b/dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Set of next generation Qt Quick controls for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+IUSE="widgets"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ widgets? ( ~dev-qt/qtwidgets-${PV} )
+"
+RDEPEND="${DEPEND}
+ ~dev-qt/qtgraphicaleffects-${PV}
+"
+
+src_prepare() {
+ qt_use_disable_mod widgets widgets \
+ src/imports/platform/platform.pro
+
+ qt5-build_src_prepare
+}