summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-19 14:40:43 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-19 15:31:19 -0500
commit06d3b70e1f807aed90b19233cc47cf9be0754198 (patch)
tree0e45657c607c0bc962db3d934c77705f39a18124 /dev-qt/qtspeech
parentdev-qt/qtshadertools: drop 6.5.3 (diff)
downloadgentoo-06d3b70e1f807aed90b19233cc47cf9be0754198.tar.gz
gentoo-06d3b70e1f807aed90b19233cc47cf9be0754198.tar.bz2
gentoo-06d3b70e1f807aed90b19233cc47cf9be0754198.zip
dev-qt/qtspeech: drop 6.5.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-6.5.3.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 225e50a4cc70..c02a2ddba265 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1,4 +1,3 @@
DIST qtspeech-5.15.11-gentoo-kde-1.tar.xz 1044 BLAKE2B 6acf62a4fdbba05604f3fc4154f8057b1a32621b5cb35de26d5e960645894248d458871678316bfc553136c31ca687804b2eefdcf342e82efd6211cf00d2760e SHA512 84780c2dcb84caba0cb2a927d4bd73f6b7285d25487451785ae56f6bfddc2d714a27954560d6ee121c9f5b464c7529276cc5415c3d49ee5dc89275dc1d005b60
DIST qtspeech-everywhere-opensource-src-5.15.11.tar.xz 104996 BLAKE2B 3272a72d8073023631c3ac18734c672b2cde2f382a011d9f02d6604093454ab7d308c0d5141d0488eb953262e8beb46e0aa1616d86db4ebabfdc3366eab32b4d SHA512 658eb9d24ea2f2bf39c6f4cd6dc75677067c8058cae694b53e665e28a273d2f730ab0dd4744ca8f8db224e52bb014fd145af1abd1667e3cd37f74c51bf96ebf4
-DIST qtspeech-everywhere-src-6.5.3.tar.xz 250112 BLAKE2B fd33ced6cd415e24789bfede90563f68e3bb63319766cb60ffb7f0708ac5f092f5cccafa840565bea6d52e5aeadd226eece9993be9f0132b65b8cabe8764a65d SHA512 d37c68cb9599e8d9a81ac070a87ed5a942e15e01401b5e179b4127aa0894a272023d717f0fc5f5c167e2ff299f79d6a19f3594172cf9779b400ac218d9587508
DIST qtspeech-everywhere-src-6.6.1.tar.xz 270752 BLAKE2B b5e5155d5313e130ef212d25fd949613bf8701ef4ac697e85f8702a94909c0d3b6c83cdc357cd5eef12bca36a1a1a0227495c2ac45ee97eabc1ff814bab0a9d5 SHA512 79a2f9192585efbea0567648e4dcbf8f36f31f28463b031378a5027c036870c67b7b15c1223fbf838fae7f8e5b036fb29ca0a631cb7d19b0a40c55588b34d5a5
diff --git a/dev-qt/qtspeech/qtspeech-6.5.3.ebuild b/dev-qt/qtspeech/qtspeech-6.5.3.ebuild
deleted file mode 100644
index 78bb4e99d6eb..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.5.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64"
-fi
-
-IUSE="flite +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtdeclarative-${PV}:6
- flite? (
- app-accessibility/flite
- ~dev-qt/qtmultimedia-${PV}:6
- )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}