summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-03 18:55:37 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:13 -0400
commit24e16820c591eb00d7995916c0a2dd0ca85d1850 (patch)
treeace41549d8607725fa5875b144056d410849b7f6 /dev-qt/qtspeech
parentdev-qt/qtsensors: new qt6 module, add 6.5.2 + live (diff)
downloadgentoo-24e16820c591eb00d7995916c0a2dd0ca85d1850.tar.gz
gentoo-24e16820c591eb00d7995916c0a2dd0ca85d1850.tar.bz2
gentoo-24e16820c591eb00d7995916c0a2dd0ca85d1850.zip
dev-qt/qtspeech: new qt6 module, add 6.5.2 + live
Packaging some extra modules that are likely needed by upcoming kde6 and were available with Qt5 in ::gentoo, so can be in a good shape by the time need these for testing. Please ask if need other modules that are still missing. wrt IUSE=speechd, normally would do IUSE=speech, but this is more specifically about enabling (optional) speechd support in a library that can do tts by other means, and also do not want it to be confused with enabling the "speech" Qt module either (nothing should need to depend on this USE). Note this module currently seems rather fragile (see ebuild comments), considered just not packaging it (yet) but it will be needed and may as well see where it goes now. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/metadata.xml2
-rw-r--r--dev-qt/qtspeech/qtspeech-6.5.2.ebuild48
-rw-r--r--dev-qt/qtspeech/qtspeech-6.5.9999.ebuild48
-rw-r--r--dev-qt/qtspeech/qtspeech-6.9999.ebuild48
5 files changed, 147 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index abbe8c534e0f..4feccbe6a821 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1,2 +1,3 @@
DIST qtspeech-5.15.10-gentoo-kde-1.tar.xz 1044 BLAKE2B e555c475fa1824ffbe34c5a0e0b6c24eeec81ad29337966e89f9dbd7d43c3a5d079603ad6dbe51e695984741cff0a749921b329242bd68d23c4ff9eed3eff008 SHA512 c4551ba08e9c23af59b9ce86d4ea0420c0b60372e3bb177d17b066b8651bb6d726c1d9981b6cf762f1cbce0fdae8f05cd77055af13384eb333355c1ba834428b
DIST qtspeech-everywhere-opensource-src-5.15.10.tar.xz 104944 BLAKE2B 7e664719d352cd29cb289f8b8f59d4595ffe343dca028a69030032030eb02c601b29492cea885bcab940264624b39042773bc70884512726abcd89dc27065b64 SHA512 b938c8baba11aa9a40a2ec5492df32c511164686aa2649d78023beccc8b23f1e0a77193672f7bc7d7f72aeb7b59fe30972683f5a4e22e1e39da9744ecd40201d
+DIST qtspeech-everywhere-src-6.5.2.tar.xz 249568 BLAKE2B af86153ea1cf0f248ab80aa828a0457e23e1f97cc5ae91bf60fa426a43a44247230b643ae48e6ae839668ea9a66edc94e0358502abcab03788cd7d1368403592 SHA512 bc6ca225f9eadc838e63bb3b011f604c1ae18eee76445c2c0d22152e473b9316b6903e349aee2555c5a110ef65fbd25ca9065b22ae4cef6e5290daa665c78434
diff --git a/dev-qt/qtspeech/metadata.xml b/dev-qt/qtspeech/metadata.xml
index aa174c30fde5..fa0f657a4256 100644
--- a/dev-qt/qtspeech/metadata.xml
+++ b/dev-qt/qtspeech/metadata.xml
@@ -8,9 +8,11 @@
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
<doc>https://doc.qt.io/</doc>
+ <remote-id type="github">qt/qtspeech</remote-id>
</upstream>
<use>
<flag name="flite">Enable text-to-speech synthesizer plugin using <pkg>app-accessibility/flite</pkg> engine</flag>
+ <flag name="speechd">Enable text-to-speech synthesizer plugin using <pkg>app-accessibility/speech-dispatcher</pkg> engine</flag>
</use>
<slots>
<subslots>
diff --git a/dev-qt/qtspeech/qtspeech-6.5.2.ebuild b/dev-qt/qtspeech/qtspeech-6.5.2.ebuild
new file mode 100644
index 000000000000..94803ab4eff3
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.5.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="flite +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtdeclarative-${PV}:6
+ flite? (
+ app-accessibility/flite
+ ~dev-qt/qtmultimedia-${PV}:6
+ )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}
diff --git a/dev-qt/qtspeech/qtspeech-6.5.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.5.9999.ebuild
new file mode 100644
index 000000000000..94803ab4eff3
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.5.9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="flite +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtdeclarative-${PV}:6
+ flite? (
+ app-accessibility/flite
+ ~dev-qt/qtmultimedia-${PV}:6
+ )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}
diff --git a/dev-qt/qtspeech/qtspeech-6.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.9999.ebuild
new file mode 100644
index 000000000000..94803ab4eff3
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="flite +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtdeclarative-${PV}:6
+ flite? (
+ app-accessibility/flite
+ ~dev-qt/qtmultimedia-${PV}:6
+ )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}