summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-28 03:05:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-28 08:31:19 -0400
commit3bbbaecf8ff805c4c5052373a4332d1795c4cc05 (patch)
treeea9fc6e8d6c8daaa5b6d09fb8091b0f9e93b5f3e /dev-qt/qtspeech
parentsys-fs/erofs-utils: keyword 1.7 for ~loong (diff)
downloadgentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.tar.gz
gentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.tar.bz2
gentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.zip
dev-qt/*: drop 6.5.9999
Technically an LTS branch but 6.5.3 is due to be the last "public" release for this branch plus Plasma 6 is based on 6.6, so should have no use for this anymore. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/qtspeech-6.5.9999.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-qt/qtspeech/qtspeech-6.5.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.5.9999.ebuild
deleted file mode 100644
index 94803ab4eff3..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.5.9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE="flite +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtdeclarative-${PV}:6
- flite? (
- app-accessibility/flite
- ~dev-qt/qtmultimedia-${PV}:6
- )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}