summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-14 06:07:13 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-14 07:20:58 -0500
commita3df1044f897829d29faaba63361ce8d4163a4ec (patch)
tree960ece514acbeeabf1f175fa4fd9a7292762f127 /dev-qt/qtspeech
parentdev-qt/qtshadertools: add 6.6.2 (diff)
downloadgentoo-a3df1044f897829d29faaba63361ce8d4163a4ec.tar.gz
gentoo-a3df1044f897829d29faaba63361ce8d4163a4ec.tar.bz2
gentoo-a3df1044f897829d29faaba63361ce8d4163a4ec.zip
dev-qt/qtspeech: add 6.6.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-6.6.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 2abb07e5cc4f..85f64c636d19 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1,3 +1,4 @@
DIST qtspeech-5.15.12-gentoo-kde-1.tar.xz 1044 BLAKE2B 680ec75681359279fab886816c078b3178e6b29af257d5163b9f5794e5ee90ad186d13029ff9a806e55f5c28d66b8e8870b15d531af8067fbed4ac86646bb00b SHA512 7773439748b85d2dd0c4d21d9e1a5e574eae848087d25b89c2cb07240021d73ea6fe62627ab061a049f7062a4b97a4316871873decc2abe0ea2cdad29ed88b1d
DIST qtspeech-everywhere-opensource-src-5.15.12.tar.xz 104816 BLAKE2B 8a64688c8ee24788498ad8eb3827cf55d4ba124230ef5f451cbf7720808d6586e48e5f0344b8546fceaf7fe048243b940f8c0bd6b44fcd5d303a1749c380ca7c SHA512 960eb661cfeb8a4fc01337ac998bc8ce101da73782155e75a7b128987d9809fa1e4cc6fee30cfa3cbd39f7fff9bbe7e49e55430681ac6582e7c8110242d7183a
DIST qtspeech-everywhere-src-6.6.1.tar.xz 270752 BLAKE2B b5e5155d5313e130ef212d25fd949613bf8701ef4ac697e85f8702a94909c0d3b6c83cdc357cd5eef12bca36a1a1a0227495c2ac45ee97eabc1ff814bab0a9d5 SHA512 79a2f9192585efbea0567648e4dcbf8f36f31f28463b031378a5027c036870c67b7b15c1223fbf838fae7f8e5b036fb29ca0a631cb7d19b0a40c55588b34d5a5
+DIST qtspeech-everywhere-src-6.6.2.tar.xz 262008 BLAKE2B 6d9ae5b42f96fa02a15ac82e9e1c6a378c3b0ceccd278af9ef99346ad79a256e41d1d2ae10cfef75f311bdfad457271357b09fd067ddc902bff3e4ee31eda12e SHA512 e43793931b81bb86cc074a2153ec0160991c86bc255ea1b11e5b4a272b8d067fcfc6788261d4b2f6f7630eadbcab7be23249b980d2792cb9a109137af614601e
diff --git a/dev-qt/qtspeech/qtspeech-6.6.2.ebuild b/dev-qt/qtspeech/qtspeech-6.6.2.ebuild
new file mode 100644
index 000000000000..867d3ddc19b8
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm64 ~loong"
+fi
+
+IUSE="flite qml +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtmultimedia-${PV}:6
+ flite? ( app-accessibility/flite )
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}