summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-03 09:39:37 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:13 -0400
commit03c260405558eb99c8b3c723e2e04cb1227b589d (patch)
tree2e1cc772318fa4fee40122fd86216c2dfa0bdaa9 /dev-qt/qtvirtualkeyboard
parentdev-qt/qtspeech: new qt6 module, add 6.5.2 + live (diff)
downloadgentoo-03c260405558eb99c8b3c723e2e04cb1227b589d.tar.gz
gentoo-03c260405558eb99c8b3c723e2e04cb1227b589d.tar.bz2
gentoo-03c260405558eb99c8b3c723e2e04cb1227b589d.zip
dev-qt/qtvirtualkeyboard: new qt6 module, add 6.5.2 + live
Packaging some extra modules that are likely needed by upcoming kde6 and were available with Qt5 in ::gentoo, so can be in a good shape by the time need these for testing. Please ask if need other modules that are still missing. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtvirtualkeyboard')
-rw-r--r--dev-qt/qtvirtualkeyboard/Manifest1
-rw-r--r--dev-qt/qtvirtualkeyboard/metadata.xml1
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.2.ebuild47
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.9999.ebuild47
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild47
5 files changed, 143 insertions, 0 deletions
diff --git a/dev-qt/qtvirtualkeyboard/Manifest b/dev-qt/qtvirtualkeyboard/Manifest
index 3f465ce021c0..cba177b398ed 100644
--- a/dev-qt/qtvirtualkeyboard/Manifest
+++ b/dev-qt/qtvirtualkeyboard/Manifest
@@ -1 +1,2 @@
DIST qtvirtualkeyboard-everywhere-opensource-src-5.15.10.tar.xz 10958048 BLAKE2B 738a31b2c9e9f8ccaf34a794da92a659c570db614a6473a96e17eb42de31395602283a600e04d871603bad99be80474895364d3689f25cbae561ea9772a97140 SHA512 6d539af5e5a336f2bf4ac1e6006268e50b426f6bb174019f742847da86f8cd5c8eb2c5f353255b5d1bba9c9c7a7b035bcb12e0063be5b31e45741ea9bd478582
+DIST qtvirtualkeyboard-everywhere-src-6.5.2.tar.xz 3735288 BLAKE2B 3c088e7b435754ed344136e4646b53ca0793824f7711829858853e3cd49bed7fb47af9caeda4d92dea46130af64eac60084256297fb3647f45127647601c20cc SHA512 acb1f5de2f0d7f985f14d8f77a37698b7ecc7db15a9911148a5f3dafa26db68f2712f9d0f2c9babec9c20b672e350e0431faed2959d2b6eb43113304ab049470
diff --git a/dev-qt/qtvirtualkeyboard/metadata.xml b/dev-qt/qtvirtualkeyboard/metadata.xml
index bbf24b44659f..e84bfa0f97be 100644
--- a/dev-qt/qtvirtualkeyboard/metadata.xml
+++ b/dev-qt/qtvirtualkeyboard/metadata.xml
@@ -11,6 +11,7 @@
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
<doc>https://doc.qt.io/</doc>
+ <remote-id type="github">qt/qtvirtualkeyboard</remote-id>
</upstream>
<slots>
<subslots>
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.2.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.2.ebuild
new file mode 100644
index 000000000000..a040a8b2bcce
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ local CMAKE_SKIP_TESTS=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ # tst_layoutfilesystem seems to fail randomly without -j1
+ qt6-build_src_test -j1
+}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.9999.ebuild
new file mode 100644
index 000000000000..a040a8b2bcce
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.5.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ local CMAKE_SKIP_TESTS=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ # tst_layoutfilesystem seems to fail randomly without -j1
+ qt6-build_src_test -j1
+}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
new file mode 100644
index 000000000000..a040a8b2bcce
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ local CMAKE_SKIP_TESTS=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ # tst_layoutfilesystem seems to fail randomly without -j1
+ qt6-build_src_test -j1
+}