summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-20 22:43:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-21 13:30:57 +0200
commitf9795d7913848b507acc9b7385cfd19725b71445 (patch)
tree76b6dc32684e0cf3a04130fe1f6d1a985459beac /dev-qt/qtwayland
parentsys-apps/fwupd: Add USE consolekit (diff)
downloadgentoo-f9795d7913848b507acc9b7385cfd19725b71445.tar.gz
gentoo-f9795d7913848b507acc9b7385cfd19725b71445.tar.bz2
gentoo-f9795d7913848b507acc9b7385cfd19725b71445.zip
dev-qt: Add Qt 5.12.3
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.12.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index b124bd9df06a..27b89960c920 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-everywhere-src-5.11.3.tar.xz 391124 BLAKE2B 2bc90c7a6f6769bcae7e52072d71f38ad984cc931767613e7972373131c9d58c145e9882c29163190257f07a205bdda63f78833859d2be6d6478126c301b70a1 SHA512 e442a13c61a508d6021fb15a0917b7861faf139fb7dca41ac1a3967f4b8dc82da5095029e4c6120464bd36ecf559547fe2f42935d9980f19298f5875cfb5e62e
DIST qtwayland-everywhere-src-5.12.2.tar.xz 431976 BLAKE2B a0f57e6dabb86817c77fc0a61dfa48dda9512961766504943b9dee816730e8f54c78fab91a6712459bb0a90b8ab168adfddfb1b363cf8dfa70339bd24dae10a7 SHA512 08fc86948b727908e668aef79c0ba558745a9dfdf394072674773d1f7a3efcfebd42a2e787d2b4214e1962101474bb637eba54d6fe526f68a747690760cbc653
+DIST qtwayland-everywhere-src-5.12.3.tar.xz 432304 BLAKE2B eb2ba520c651467c8ed5f0d870a69c9b07047cb4c05a0c889b36abeab30149861b83ca693efb0bb93dce4f5da5913afc3c8b61933ef0e8307d22b64fce530d87 SHA512 e66f9f41c15cf84165e559a1ff09e20ec21bb3f909b57fab08b0e3f8f9eeacf75d49541b499b1a6514a34d1ba5dd426ec1ce77719910588afa12cb3a7980dc90
diff --git a/dev-qt/qtwayland/qtwayland-5.12.3.ebuild b/dev-qt/qtwayland/qtwayland-5.12.3.ebuild
new file mode 100644
index 000000000000..dcdeeaa61c32
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.12.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ src/plugins/shellintegration/wl-shell/wl-shell.pro \
+ src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
+ src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
+ src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}