summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-24 02:57:01 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-24 03:23:11 +1000
commit421e93435a836b5245edd3e97a533ab806941e91 (patch)
treed4ef6b3cf40176ce99ac82a1d6f9144532d93842 /dev-qt/qtxml/qtxml-5.6.0.ebuild
parentapp-emulation/qemu-guest-agent: fix build w/newer glibc #580924 (diff)
downloadgentoo-421e93435a836b5245edd3e97a533ab806941e91.tar.gz
gentoo-421e93435a836b5245edd3e97a533ab806941e91.tar.bz2
gentoo-421e93435a836b5245edd3e97a533ab806941e91.zip
dev-qt: version bump 5.6.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.6.0.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.6.0.ebuild b/dev-qt/qtxml/qtxml-5.6.0.ebuild
new file mode 100644
index 000000000000..7a281cb1af75
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="SAX and DOM implementation library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)