summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-10 20:50:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-10 21:27:01 +0100
commit07df47de4fba65ea226811b9b6f586290cf7035c (patch)
tree3ea7fb10d5300904cd599aff87aadd15570cb07b /dev-qt
parentdev-python/cheroot: drop pypy support (diff)
downloadgentoo-07df47de4fba65ea226811b9b6f586290cf7035c.tar.gz
gentoo-07df47de4fba65ea226811b9b6f586290cf7035c.tar.bz2
gentoo-07df47de4fba65ea226811b9b6f586290cf7035c.zip
dev-qt/qtwebengine: Update paxmark-mksnapshot patches for 5.11.{1,2}
Reported-by: Han <jkmls@outlook.com> Thanks-to: Attila Tóth <atoth@atoth.sote.hu> Thanks-to: Miroslaw Mieszczak <gentoo@mieszczak.com.pl> Closes: https://bugs.gentoo.org/670852 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.11.1-paxmark-mksnapshot.patch41
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch41
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.11.1.ebuild2
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.11.2.ebuild2
4 files changed, 84 insertions, 2 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.11.1-paxmark-mksnapshot.patch b/dev-qt/qtwebengine/files/qtwebengine-5.11.1-paxmark-mksnapshot.patch
new file mode 100644
index 000000000000..352deefb22ac
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.11.1-paxmark-mksnapshot.patch
@@ -0,0 +1,41 @@
+Bug: https://bugs.gentoo.org/634220
+
+--- a/src/3rdparty/chromium/v8/BUILD.gn
++++ b/src/3rdparty/chromium/v8/BUILD.gn
+@@ -661,6 +661,7 @@ action("run_mksnapshot") {
+
+ deps = [
+ ":mksnapshot($v8_snapshot_toolchain)",
++ ":run_paxmark",
+ ]
+
+ script = "tools/run.py"
+@@ -706,6 +707,28 @@ action("run_mksnapshot") {
+ args += [ rebase_path(v8_embed_script, root_build_dir) ]
+ }
+ }
++action("run_paxmark") {
++ visibility = [ ":*" ] # Only targets in this file can depend on this.
++
++ deps = [
++ ":mksnapshot($v8_snapshot_toolchain)",
++ ]
++
++ script = "/usr/sbin/pypaxctl"
++
++ sources = []
++
++ outputs = [
++ "$target_out_dir/mksnapshot",
++ ]
++
++ args = [
++ "-sm",
++ "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
++ "root_out_dir") + "/mksnapshot",
++ root_build_dir),
++ ]
++}
+
+ action("run_mkpeephole") {
+ visibility = [ ":*" ] # Only targets in this file can depend on this.
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch b/dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch
new file mode 100644
index 000000000000..f7a5c064fc4e
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch
@@ -0,0 +1,41 @@
+Bug: https://bugs.gentoo.org/634220
+
+--- a/src/3rdparty/chromium/v8/BUILD.gn
++++ b/src/3rdparty/chromium/v8/BUILD.gn
+@@ -803,6 +803,7 @@
+
+ deps = [
+ ":mksnapshot($v8_snapshot_toolchain)",
++ ":run_paxmark",
+ ]
+
+ script = "tools/run.py"
+@@ -854,6 +855,28 @@
+ }
+ }
+ }
++action("run_paxmark") {
++ visibility = [ ":*" ] # Only targets in this file can depend on this.
++
++ deps = [
++ ":mksnapshot($v8_snapshot_toolchain)",
++ ]
++
++ script = "/usr/sbin/pypaxctl"
++
++ sources = []
++
++ outputs = [
++ "$target_out_dir/mksnapshot",
++ ]
++
++ args = [
++ "-sm",
++ "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
++ "root_out_dir") + "/mksnapshot",
++ root_build_dir),
++ ]
++}
+
+ action("v8_dump_build_config") {
+ script = "tools/testrunner/utils/dump_build_config.py"
diff --git a/dev-qt/qtwebengine/qtwebengine-5.11.1.ebuild b/dev-qt/qtwebengine/qtwebengine-5.11.1.ebuild
index ba8cd487b93d..72de09bfac98 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.11.1.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.11.1.ebuild
@@ -86,7 +86,7 @@ PATCHES+=(
)
src_prepare() {
- use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
+ use pax_kernel && PATCHES+=( "${FILESDIR}/${P}-paxmark-mksnapshot.patch" )
# bug 620444 - ensure local headers are used
find "${S}" -type f -name "*.pr[fio]" | xargs sed -i -e 's|INCLUDEPATH += |&$$QTWEBENGINE_ROOT/include |' || die
diff --git a/dev-qt/qtwebengine/qtwebengine-5.11.2.ebuild b/dev-qt/qtwebengine/qtwebengine-5.11.2.ebuild
index 57fa9ada481e..90eb3ad29441 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.11.2.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.11.2.ebuild
@@ -84,7 +84,7 @@ PATCHES+=(
)
src_prepare() {
- use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
+ use pax_kernel && PATCHES+=( "${FILESDIR}/${P}-paxmark-mksnapshot.patch" )
if ! use jumbo-build; then
sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \