summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-28 16:45:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-28 16:58:41 +0200
commit2b77233d485dc1960d0c24ab7148867c838d9b05 (patch)
treedd51f191966199bd96410f7b4b35143c521891f4 /dev-qt
parentwww-client/surf: keyword ~riscv (diff)
downloadgentoo-2b77233d485dc1960d0c24ab7148867c838d9b05.tar.gz
gentoo-2b77233d485dc1960d0c24ab7148867c838d9b05.tar.bz2
gentoo-2b77233d485dc1960d0c24ab7148867c838d9b05.zip
dev-qt/qtwayland: 5.15.2-r13 version bump at KDE efe6edca
"Client: Don't always recreate frame callbacks" See also: https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/16 QTBUG: https://bugreports-test.qt.io/browse/QTBUG-81504 "Wayland client: Fix crash when windows are shown/hidden during drag" See also: https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/17 QTBUG: https://bugreports-test.qt.io/browse/QTBUG-87624 Bug: https://bugs.gentoo.org/806797 Package-Manager: Portage-3.0.24, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r13.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 9e110f7478ca..70b2d66acb49 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-5.15.2-3c420cd1.tar.gz 829193 BLAKE2B dcd6f466184263b8988f5ae8e8cd47d22711ec791d5f7afdc156ce6de31488f6b37970bac00edbbe9a485b3627f86f865e45d9515e48eccf37cc12a831d7740e SHA512 d4e247d08ed17a31073005b4bef818571cd1268f8b4a430dd366f680a0f652d3aa321ea264efc88628405ac254693bdc1b34d32a2bcb14f4d987d5380e4cedfc
+DIST qtwayland-5.15.2-efe6edca.tar.gz 829293 BLAKE2B 6ccc5a4e111818cc65855eb4570727f30932bec9a749069550d07332df719eaeec0baf472c025150a32c9c380294f5e9496ad3babd181887a02fc37d1bfd5f2a SHA512 87190cd1ade57c98da972a2f5d48aa0376ccc4bfa589f5832b8a62a63b3eafa6acf88d812ae98c484d4b02878ae2c1986c3759c0ba3f46894c76af713d7b8346
DIST qtwayland-everywhere-src-5.15.2.tar.xz 564884 BLAKE2B 472effd3e9f3fd5470e0449703a52d45f2fd823770880b5ad15d8bf99196eee5d8511ca2bc9e23df6e27c933551d1853928ba79b4b1e5fa6e53334c54c04a463 SHA512 e8657ed676873da7b949e6a1605d025918a03336af9c68f32741945ec3c71a604def55bb00737ba4d97b91c00d0e2df1a83cdcedcf5795c6b2a1ef2caa21c91c
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r13.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r13.ebuild
new file mode 100644
index 000000000000..04ad1dcd63c4
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2-r13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=efe6edcaf8eba601dff99ec6ad4457c8a4442f86
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ >=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}