summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-19 14:10:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-19 14:24:38 +0200
commit427896c74254dc96deb857ccb7d57c766a5bee3d (patch)
tree2adc325cd1792aaa24ff6ced05ec596c3620bf78 /dev-qt
parentdev-qt/qtimageformats: 5.15.5 version bump (diff)
downloadgentoo-427896c74254dc96deb857ccb7d57c766a5bee3d.tar.gz
gentoo-427896c74254dc96deb857ccb7d57c766a5bee3d.tar.bz2
gentoo-427896c74254dc96deb857ccb7d57c766a5bee3d.zip
dev-qt/qtlocation: 5.15.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/Manifest2
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.5.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index af94166f5f5e..b893d0229eb7 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,2 +1,4 @@
DIST qtlocation-5.15.4-gentoo-kde-1.tar.xz 1000 BLAKE2B d50546826373a9123f91d2e21f670c030a4a9530494c4ab173a4045f79ea7c6907e39c0acb57e7e3e872146ad72785c4b72b7257672e432ff5870730f66a54cc SHA512 5d2217a3d40b873cd6b0b7c7815a9a52aa19824b7c2aed1d1ea3dac2fafa8b2af9a62ff3dacbdcb588072f2edb1cb226bc808d094ca4c6240a58835d4e93854c
+DIST qtlocation-5.15.5-gentoo-kde-1.tar.xz 3952 BLAKE2B ddab14fa3b17d080ea47a6bc10c3ca8fe180ff4954f22833967d1938f06c657c86c2e186e5c6bb50e3fd65c6c0c0b5cc94527bd687b714a315f23dcb7762c606 SHA512 f20b5aea6d68ab6860d69369d58b777ff56de3e2d93e3cbdadd21e6e0fb3511829d5c28b918c19e10290c1e5add0d087f98b2b005ac2f9a5381b9d59fd626a59
DIST qtlocation-everywhere-opensource-src-5.15.4.tar.xz 6559260 BLAKE2B ea43ae7e788f7d117fea9db50660cc2f4e7b6f8cf4ae390b41ed3adfa794d66596d8d7ac184d1edc432d2aa6057727321459a29ddbe399201ad428d290982297 SHA512 6208052d6ac173d19dc77496d8108558e7f31696dc5792fcbbeef2029539db76a60c5a51a7d198f54ea6c0ec23977a57cd8c8f8fa80fe5eac9528d2510c3dbb3
+DIST qtlocation-everywhere-opensource-src-5.15.5.tar.xz 6559912 BLAKE2B 4f546293b2cfddf5512f3648aef9c527762d6c6ddbaca6583cf0287178524bae9f84e4b94950ce1139042efa995a4f31ef20f26b8d5479048df2ba75cac35d23 SHA512 5090f68926a7bc2f25ea5ae259cb87653b83fcf337c3255a7a2700724f6ac83ec2e1d9b6f38f185ab7dab84e5e042b72c58f4e4cacada6fb7d729378b93d9b3e
diff --git a/dev-qt/qtlocation/qtlocation-5.15.5.ebuild b/dev-qt/qtlocation/qtlocation-5.15.5.ebuild
new file mode 100644
index 000000000000..ba9e9fc91df0
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}