summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-07 00:55:34 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-07 00:55:52 +1100
commit55f59ac5cc002e55c5471fd69f031261f9481d99 (patch)
tree8ed5b3cae72e3d96dda6cb3e96d1ccd2e85df19a /dev-qt
parentdev-lang/php: Drop old vulnerable versions (diff)
downloadgentoo-55f59ac5cc002e55c5471fd69f031261f9481d99.tar.gz
gentoo-55f59ac5cc002e55c5471fd69f031261f9481d99.tar.bz2
gentoo-55f59ac5cc002e55c5471fd69f031261f9481d99.zip
dev-qt/qtmultimedia: revision bump avoids adding unrequested CFLAGS
Closes: https://bugs.gentoo.org/646756 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-5.9.4-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-qt/qtmultimedia/qtmultimedia-5.9.4-r1.ebuild b/dev-qt/qtmultimedia/qtmultimedia-5.9.4-r1.ebuild
new file mode 100644
index 000000000000..e5a416d9fbfe
--- /dev/null
+++ b/dev-qt/qtmultimedia/qtmultimedia-5.9.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Multimedia (audio, video, radio, camera) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="alsa gles2 gstreamer openal pulseaudio qml widgets"
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[gles2=]
+ ~dev-qt/qtnetwork-${PV}
+ alsa? ( media-libs/alsa-lib )
+ gstreamer? (
+ dev-libs/glib:2
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ qml? (
+ ~dev-qt/qtdeclarative-${PV}
+ gles2? ( ~dev-qt/qtgui-${PV}[egl] )
+ openal? ( media-libs/openal )
+ )
+ widgets? (
+ ~dev-qt/qtopengl-${PV}
+ ~dev-qt/qtwidgets-${PV}[gles2=]
+ )
+"
+DEPEND="${RDEPEND}
+ gstreamer? ( x11-proto/videoproto )
+"
+
+src_prepare() {
+ # bug 646756
+ sed -i -e '/CONFIG\s*+=/ s/optimize_full//' \
+ src/multimedia/multimedia.pro || die
+
+ qt_use_disable_config openal openal \
+ src/imports/imports.pro
+
+ qt_use_disable_mod qml quick \
+ src/src.pro \
+ src/plugins/plugins.pro
+
+ qt_use_disable_mod widgets widgets \
+ src/src.pro \
+ src/gsttools/gsttools.pro \
+ src/plugins/gstreamer/common.pri
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use alsa)
+ $(qt_use gstreamer)
+ $(qt_use pulseaudio)
+ )
+ qt5-build_src_configure
+}