summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-19 14:10:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-19 14:24:34 +0200
commit965cdffb84a5b11126b82c9904144dd985de70e5 (patch)
tree33720efff7ad579e37f8abc1a89c624b2dd265e8 /dev-qt
parentdev-qt/linguist: 5.15.5 version bump (diff)
downloadgentoo-965cdffb84a5b11126b82c9904144dd985de70e5.tar.gz
gentoo-965cdffb84a5b11126b82c9904144dd985de70e5.tar.bz2
gentoo-965cdffb84a5b11126b82c9904144dd985de70e5.zip
dev-qt/linguist-tools: 5.15.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/linguist-tools/Manifest1
-rw-r--r--dev-qt/linguist-tools/linguist-tools-5.15.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-qt/linguist-tools/Manifest b/dev-qt/linguist-tools/Manifest
index f5d77da7d6ad..bf6b080d0ab0 100644
--- a/dev-qt/linguist-tools/Manifest
+++ b/dev-qt/linguist-tools/Manifest
@@ -1,2 +1,3 @@
DIST qttools-5.15.4-gentoo-kde-1.tar.xz 1320 BLAKE2B 6e25237a0c36380e55dc48c04bc01a9d1ac0d398f47bde09ef2435d97267a38a5c74af856ef4544727292c3aa0bf10f305529b7ccc24b4565c60119dd5597559 SHA512 19ea717ccd5c053037206cdd2dc533f285306c207fcc0daf46fba6e2d6fcde3561043b45da4bc830bb181bad46904b191149b65c5bb76414bd975f1a4706afef
DIST qttools-everywhere-opensource-src-5.15.4.tar.xz 8897256 BLAKE2B e7d8055c9b4b52b188f61c73a300275838647d95f9eb0437129482d91584bbc0705ce9360b0a8fee2775a4cfefda53bc5aae70b10ca34d1bdeb09aa19b7d13bb SHA512 26edf546a1ec7195f1ff5a9e40e430fdd0c7ebb7d86e44ed22b093426c23ff25b2c972fa520abd1064369d32609019746c2fe972a3f593c6f7539d339642f06e
+DIST qttools-everywhere-opensource-src-5.15.5.tar.xz 8898140 BLAKE2B 49b7b0db9d9ae9c6d405678eab0ec097bc160eb7787bc939aa92816cc63c5c97aef2de0c978a2a3597014878dca9466631131bc7746bd03d87229ed7edb6594c SHA512 ff5e658ec812dd36d00ad3ac7e824de708968ff1c66a73da1470b6f0cdb6853a7084f18b1bcf1614afd4c23f381d817d7eb665f8573a4e981a9b87c6e4d6fa2b
diff --git a/dev-qt/linguist-tools/linguist-tools-5.15.5.ebuild b/dev-qt/linguist-tools/linguist-tools-5.15.5.ebuild
new file mode 100644
index 000000000000..fa97b5836283
--- /dev/null
+++ b/dev-qt/linguist-tools/linguist-tools-5.15.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Tools for working with Qt translation data files"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtxml-${QT5_PV}*
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist
+)
+
+src_prepare() {
+ sed -i -e '/SUBDIRS += linguist/d' \
+ src/linguist/linguist.pro || die
+
+ qt_use_disable_mod qml qmldevtools-private \
+ src/linguist/lupdate/lupdate.pro
+
+ qt5-build_src_prepare
+}