summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2020-07-12 04:01:23 +0200
committerDavide Pesavento <pesa@gentoo.org>2020-07-12 04:02:44 +0200
commita98a03b54b43acd6647a45eed5cde232a0ea3ffb (patch)
treec9ad1017c22027151884f76c00f23440b5e581d3 /dev-qt
parentmedia-video/rav1e: arm keyworded (bug #728558) (diff)
downloadgentoo-a98a03b54b43acd6647a45eed5cde232a0ea3ffb.tar.gz
gentoo-a98a03b54b43acd6647a45eed5cde232a0ea3ffb.tar.bz2
gentoo-a98a03b54b43acd6647a45eed5cde232a0ea3ffb.zip
dev-qt/qt-creator: add USE=qmljs
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qt-creator/metadata.xml15
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild8
2 files changed, 14 insertions, 9 deletions
diff --git a/dev-qt/qt-creator/metadata.xml b/dev-qt/qt-creator/metadata.xml
index de392789cbb8..6e40ad6ef7ff 100644
--- a/dev-qt/qt-creator/metadata.xml
+++ b/dev-qt/qt-creator/metadata.xml
@@ -12,35 +12,36 @@
<use>
<flag name="android">Build plugin for Android devices</flag>
<flag name="autotest">Enable integration with popular unit testing frameworks (QtTest, Google Test, Boost.Test)</flag>
- <flag name="autotools">Enable autotools project manager plugin</flag>
+ <flag name="autotools">Build plugin for autotools-based projects</flag>
<flag name="baremetal">Build plugin for bare metal devices</flag>
<flag name="bazaar">Add support for GNU Bazaar version control system (requires manual installation of Bazaar client)</flag>
<flag name="beautifier">Build the beautifier plugin (supports astyle, clang-format, and uncrustify)</flag>
<flag name="boot2qt">Build plugin for Boot2Qt devices</flag>
<flag name="clang">Build clang-based plugins (code model, formatting, refactoring, static analysis)</flag>
<flag name="clearcase">Add support for IBM ClearCase version control system (requires manual installation of ClearCase client)</flag>
- <flag name="cmake">Enable cmake project manager plugin</flag>
+ <flag name="cmake">Build plugin for CMake-based projects</flag>
<flag name="cppcheck">Enable integration with <pkg>dev-util/cppcheck</pkg></flag>
<flag name="ctfvisualizer">Build the Chrome Trace Format visualizer plugin</flag>
<flag name="designer">Enable designer for QtWidgets-based UIs</flag>
- <flag name="glsl">Enable GLSL editor</flag>
+ <flag name="glsl">Build the GLSL editor plugin</flag>
<flag name="help">Enable the integrated documentation viewer</flag>
<flag name="ios">Build plugin for Apple iOS devices</flag>
<flag name="lsp">Add support for the Language Server Protocol (LSP)</flag>
<flag name="mcu">Build plugin for MCU devices</flag>
<flag name="mercurial">Add support for <pkg>dev-vcs/mercurial</pkg> version control system</flag>
- <flag name="modeling">Enable graphical model editor</flag>
+ <flag name="modeling">Build the graphical model editor plugin</flag>
<flag name="nim">Build plugin for Nim language support</flag>
<flag name="perforce">Add support for Perforce version control system (requires manual installation of Perforce client)</flag>
<flag name="perfprofiler">Build the Linux Perf-based profiler plugin</flag>
<flag name="python">Build plugin for Python language support</flag>
- <flag name="qbs">Enable QBS project manager plugin</flag>
+ <flag name="qbs">Build plugin for QBS-based projects</flag>
<flag name="qmldesigner">Enable designer for QML/QtQuick-based UIs</flag>
+ <flag name="qmljs">Build the QML/JavaScript editor plugin</flag>
<flag name="qmlprofiler">Build the QML profiler plugin</flag>
<flag name="qnx">Build plugin for QNX devices</flag>
<flag name="remotelinux">Add support for deployment and execution on a remote Linux host</flag>
- <flag name="scxml">Enable graphical SCXML editor</flag>
- <flag name="serialterminal">Build serial terminal plugin</flag>
+ <flag name="scxml">Build the graphical SCXML editor plugin</flag>
+ <flag name="serialterminal">Build the serial terminal plugin</flag>
<flag name="silversearcher">Enable integration with <pkg>sys-apps/the_silver_searcher</pkg></flag>
<flag name="systemd">Add support for retrieving application output from journald</flag>
<flag name="valgrind">Enable integration with <pkg>dev-util/valgrind</pkg></flag>
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index 16ef16cdafb0..9ae9556b4db1 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -30,8 +30,8 @@ QTC_PLUGINS=(android +autotest autotools:autotoolsprojectmanager baremetal bazaa
'+clang:clangcodemodel|clangformat|clangpchmanager|clangrefactoring|clangtools' clearcase
cmake:cmakeprojectmanager cppcheck ctfvisualizer cvs +designer git glsl:glsleditor +help
lsp:languageclient mcu:mcusupport mercurial modeling:modeleditor nim perforce perfprofiler python
- qbs:qbsprojectmanager +qmldesigner qmlprofiler qnx remotelinux scxml:scxmleditor serialterminal
- silversearcher subversion valgrind webassembly)
+ qbs:qbsprojectmanager +qmldesigner +qmljs:qmljseditor qmlprofiler qnx remotelinux scxml:scxmleditor
+ serialterminal silversearcher subversion valgrind webassembly)
IUSE="doc systemd test webengine ${QTC_PLUGINS[@]%:*}"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -39,6 +39,7 @@ REQUIRED_USE="
clang? ( test? ( qbs ) )
mcu? ( cmake )
python? ( lsp )
+ qmldesigner? ( qmljs )
qnx? ( remotelinux )
"
@@ -165,6 +166,9 @@ src_prepare() {
sed -i -e '/qml2puppet/d' src/tools/tools.pro || die
sed -i -e '/qmldesigner/d' tests/auto/qml/qml.pro || die
fi
+ if ! use qmljs; then
+ sed -i -e '/qmleditorwidgets/d' src/libs/libs.pro || die
+ fi
if ! use valgrind; then
sed -i -e '/valgrindfake/d' src/tools/tools.pro || die
sed -i -e '/valgrind/d' tests/auto/auto.pro || die