summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-11 00:15:13 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-11 00:15:55 +0200
commitc725aea714f6dec6c9812ed62be85eca0b42d6a1 (patch)
treecbda383c10e98f23366dbc4a5bf74be233486578 /dev-qt
parentdev-libs/hiredis: security cleanup (diff)
downloadgentoo-c725aea714f6dec6c9812ed62be85eca0b42d6a1.tar.gz
gentoo-c725aea714f6dec6c9812ed62be85eca0b42d6a1.tar.bz2
gentoo-c725aea714f6dec6c9812ed62be85eca0b42d6a1.zip
dev-qt/qtcore: renameat2 is glibc specific
We let Qt do the detection and only pass -no-foo when old-kernel is requested. Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtcore/qtcore-5.14.2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-qt/qtcore/qtcore-5.14.2.ebuild b/dev-qt/qtcore/qtcore-5.14.2.ebuild
index cf3d58126f19..e1f44b0b6e03 100644
--- a/dev-qt/qtcore/qtcore-5.14.2.ebuild
+++ b/dev-qt/qtcore/qtcore-5.14.2.ebuild
@@ -53,8 +53,8 @@ pkg_pretend() {
use kernel_linux || return
get_running_version
if kernel_is -lt 3 17 && ! use old-kernel; then
- ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for ${CATEGORY}/${PN}"
- ewarn "to function on this kernel properly. See Bug #669994."
+ ewarn "The running kernel is older than 3.17. USE=old-kernel is needed for"
+ ewarn "dev-qt/qtcore to function on this kernel properly. See Bug #669994."
fi
}
@@ -73,10 +73,12 @@ src_configure() {
-no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
- $(qt_use !old-kernel feature-renameat2) # needs Linux 3.16, bug 669994
- $(qt_use !old-kernel feature-getentropy) # needs Linux 3.17, bug 669994
$(qt_use systemd journald)
)
+ use old-kernel && myconf+=(
+ -no-feature-renameat2 # needs Linux 3.16, bug 669994
+ -no-feature-getentropy # needs Linux 3.17, bug 669994
+ )
qt5-build_src_configure
}