summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-28 11:06:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-08 18:54:44 +0200
commiteb5d79adbde868b2d62fd78b6b031ed435483d74 (patch)
treeef5c228da19b36cee7dec42281c790f9d1a6cfcd /dev-qt
parentdev-qt/qtsingleapplication: EAPI-8 bump (diff)
downloadgentoo-eb5d79adbde868b2d62fd78b6b031ed435483d74.tar.gz
gentoo-eb5d79adbde868b2d62fd78b6b031ed435483d74.tar.bz2
gentoo-eb5d79adbde868b2d62fd78b6b031ed435483d74.zip
dev-qt: EAPI-8 bumps, switch from ~PV to =QT5_PV* version dependencies
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.15.2-r1.ebuild (renamed from dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild)12
-rw-r--r--dev-qt/qtcharts/qtcharts-5.15.2-r1.ebuild (renamed from dev-qt/qtcharts/qtcharts-5.15.2.ebuild)11
-rw-r--r--dev-qt/qtdatavis3d/qtdatavis3d-5.15.2-r1.ebuild (renamed from dev-qt/qtdatavis3d/qtdatavis3d-5.15.2.ebuild)9
-rw-r--r--dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.15.2-r1.ebuild (renamed from dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.15.2.ebuild)9
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-5.15.2-r1.ebuild (renamed from dev-qt/qtmultimedia/qtmultimedia-5.15.2.ebuild)17
-rw-r--r--dev-qt/qtnetworkauth/qtnetworkauth-5.15.2-r1.ebuild (renamed from dev-qt/qtnetworkauth/qtnetworkauth-5.15.2.ebuild)7
-rw-r--r--dev-qt/qtpositioning/qtpositioning-5.15.2-r1.ebuild (renamed from dev-qt/qtpositioning/qtpositioning-5.15.2.ebuild)9
-rw-r--r--dev-qt/qtquickcontrols/qtquickcontrols-5.15.2-r1.ebuild (renamed from dev-qt/qtquickcontrols/qtquickcontrols-5.15.2.ebuild)11
-rw-r--r--dev-qt/qtquicktimeline/qtquicktimeline-5.15.2-r1.ebuild (renamed from dev-qt/qtquicktimeline/qtquicktimeline-5.15.2.ebuild)8
-rw-r--r--dev-qt/qtscript/qtscript-5.15.2-r1.ebuild (renamed from dev-qt/qtscript/qtscript-5.15.2.ebuild)9
-rw-r--r--dev-qt/qtscxml/qtscxml-5.15.2-r1.ebuild (renamed from dev-qt/qtscxml/qtscxml-5.15.2.ebuild)7
-rw-r--r--dev-qt/qtsensors/qtsensors-5.15.2-r1.ebuild (renamed from dev-qt/qtsensors/qtsensors-5.15.2.ebuild)9
-rw-r--r--dev-qt/qtserialbus/qtserialbus-5.15.2-r1.ebuild (renamed from dev-qt/qtserialbus/qtserialbus-5.15.2.ebuild)11
-rw-r--r--dev-qt/qtserialport/qtserialport-5.15.2-r1.ebuild (renamed from dev-qt/qtserialport/qtserialport-5.15.2.ebuild)5
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-5.15.2-r1.ebuild (renamed from dev-qt/qtwebchannel/qtwebchannel-5.15.2.ebuild)7
-rw-r--r--dev-qt/qtwebview/qtwebview-5.15.2-r2.ebuild (renamed from dev-qt/qtwebview/qtwebview-5.15.2-r1.ebuild)8
-rw-r--r--dev-qt/qtx11extras/qtx11extras-5.15.2-r1.ebuild (renamed from dev-qt/qtx11extras/qtx11extras-5.15.2.ebuild)8
17 files changed, 85 insertions, 72 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.15.2-r1.ebuild
index ab26257c7e41..1a88564f814e 100644
--- a/dev-qt/qtbluetooth/qtbluetooth-5.15.2.ebuild
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.15.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
QT5_MODULE="qtconnectivity"
inherit qt5-build
@@ -15,14 +15,14 @@ fi
IUSE="qml"
RDEPEND="
- ~dev-qt/qtconcurrent-${PV}
- ~dev-qt/qtcore-${PV}:5=
- ~dev-qt/qtdbus-${PV}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdbus-${QT5_PV}*
>=net-wireless/bluez-5:=
- qml? ( ~dev-qt/qtdeclarative-${PV} )
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
DEPEND="${RDEPEND}
- ~dev-qt/qtnetwork-${PV}
+ =dev-qt/qtnetwork-${QT5_PV}*
"
PATCHES=( "${FILESDIR}/${P}-gcc11.patch" ) # bug 752012
diff --git a/dev-qt/qtcharts/qtcharts-5.15.2.ebuild b/dev-qt/qtcharts/qtcharts-5.15.2-r1.ebuild
index f9ace0931949..a23f9413e208 100644
--- a/dev-qt/qtcharts/qtcharts-5.15.2.ebuild
+++ b/dev-qt/qtcharts/qtcharts-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Chart component library for the Qt5 framework"
@@ -14,10 +15,10 @@ fi
IUSE="qml"
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtwidgets-${QT5_PV}*
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtdatavis3d/qtdatavis3d-5.15.2.ebuild b/dev-qt/qtdatavis3d/qtdatavis3d-5.15.2-r1.ebuild
index 46e32e2b4d71..4963f2fe39af 100644
--- a/dev-qt/qtdatavis3d/qtdatavis3d-5.15.2.ebuild
+++ b/dev-qt/qtdatavis3d/qtdatavis3d-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="3D data visualization library for the Qt5 framework"
@@ -14,9 +15,9 @@ fi
IUSE="gles2-only qml"
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2-only=]
- qml? ( ~dev-qt/qtdeclarative-${PV}[gles2-only=] )
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*[gles2-only=]
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}*[gles2-only=] )
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.15.2.ebuild b/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.15.2-r1.ebuild
index 4ad065e1ce37..216671e4f052 100644
--- a/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.15.2.ebuild
+++ b/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
VIRTUALX_REQUIRED="test"
inherit qt5-build
@@ -14,8 +15,8 @@ fi
IUSE=""
RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
"
DEPEND="${RDEPEND}"
diff --git a/dev-qt/qtmultimedia/qtmultimedia-5.15.2.ebuild b/dev-qt/qtmultimedia/qtmultimedia-5.15.2-r1.ebuild
index d7aa5646506c..2ed94944ea31 100644
--- a/dev-qt/qtmultimedia/qtmultimedia-5.15.2.ebuild
+++ b/dev-qt/qtmultimedia/qtmultimedia-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Multimedia (audio, video, radio, camera) library for the Qt5 framework"
@@ -13,9 +14,9 @@ fi
IUSE="alsa gles2-only gstreamer openal pulseaudio qml widgets"
RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2-only=]
- ~dev-qt/qtnetwork-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*[gles2-only=]
+ =dev-qt/qtnetwork-${QT5_PV}*
alsa? ( media-libs/alsa-lib )
gstreamer? (
dev-libs/glib:2
@@ -25,13 +26,13 @@ RDEPEND="
)
pulseaudio? ( media-sound/pulseaudio[glib] )
qml? (
- ~dev-qt/qtdeclarative-${PV}
- gles2-only? ( ~dev-qt/qtgui-${PV}[egl] )
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ gles2-only? ( =dev-qt/qtgui-${QT5_PV}*[egl] )
openal? ( media-libs/openal )
)
widgets? (
- ~dev-qt/qtopengl-${PV}
- ~dev-qt/qtwidgets-${PV}[gles2-only=]
+ =dev-qt/qtopengl-${QT5_PV}*
+ =dev-qt/qtwidgets-${QT5_PV}*[gles2-only=]
)
"
DEPEND="${RDEPEND}
diff --git a/dev-qt/qtnetworkauth/qtnetworkauth-5.15.2.ebuild b/dev-qt/qtnetworkauth/qtnetworkauth-5.15.2-r1.ebuild
index ab41e5c6f79a..427cf618df8a 100644
--- a/dev-qt/qtnetworkauth/qtnetworkauth-5.15.2.ebuild
+++ b/dev-qt/qtnetworkauth/qtnetworkauth-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Network authorization library for the Qt5 framework"
@@ -14,7 +15,7 @@ fi
IUSE=""
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtnetwork-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtpositioning/qtpositioning-5.15.2.ebuild b/dev-qt/qtpositioning/qtpositioning-5.15.2-r1.ebuild
index bffa2b8cacf2..6154ad6744ae 100644
--- a/dev-qt/qtpositioning/qtpositioning-5.15.2.ebuild
+++ b/dev-qt/qtpositioning/qtpositioning-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
QT5_MODULE="qtlocation"
inherit qt5-build
@@ -14,9 +15,9 @@ fi
IUSE="geoclue +qml"
RDEPEND="
- ~dev-qt/qtcore-${PV}
- geoclue? ( ~dev-qt/qtdbus-${PV} )
- qml? ( ~dev-qt/qtdeclarative-${PV} )
+ =dev-qt/qtcore-${QT5_PV}*
+ geoclue? ( =dev-qt/qtdbus-${QT5_PV}* )
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
DEPEND="${RDEPEND}"
PDEPEND="
diff --git a/dev-qt/qtquickcontrols/qtquickcontrols-5.15.2.ebuild b/dev-qt/qtquickcontrols/qtquickcontrols-5.15.2-r1.ebuild
index 91ad5b9e09f6..494d453b030b 100644
--- a/dev-qt/qtquickcontrols/qtquickcontrols-5.15.2.ebuild
+++ b/dev-qt/qtquickcontrols/qtquickcontrols-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Set of Qt Quick controls to create complete user interfaces (deprecated)"
@@ -13,10 +14,10 @@ fi
IUSE="+widgets"
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- widgets? ( ~dev-qt/qtwidgets-${PV} )
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ widgets? ( =dev-qt/qtwidgets-${QT5_PV}* )
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtquicktimeline/qtquicktimeline-5.15.2.ebuild b/dev-qt/qtquicktimeline/qtquicktimeline-5.15.2-r1.ebuild
index bf8d344fb0b3..3ba1e4d5dceb 100644
--- a/dev-qt/qtquicktimeline/qtquicktimeline-5.15.2.ebuild
+++ b/dev-qt/qtquicktimeline/qtquicktimeline-5.15.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit qt5-build
@@ -12,7 +12,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
fi
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtscript/qtscript-5.15.2.ebuild b/dev-qt/qtscript/qtscript-5.15.2-r1.ebuild
index 654014235025..00e1e6cc7370 100644
--- a/dev-qt/qtscript/qtscript-5.15.2.ebuild
+++ b/dev-qt/qtscript/qtscript-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"
@@ -13,10 +14,10 @@ fi
IUSE="+jit scripttools"
DEPEND="
- ~dev-qt/qtcore-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
scripttools? (
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtwidgets-${QT5_PV}*
)
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtscxml/qtscxml-5.15.2.ebuild b/dev-qt/qtscxml/qtscxml-5.15.2-r1.ebuild
index 8a38c015dba4..03ff5ecc0229 100644
--- a/dev-qt/qtscxml/qtscxml-5.15.2.ebuild
+++ b/dev-qt/qtscxml/qtscxml-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="State Chart XML (SCXML) support library for the Qt5 framework"
@@ -13,7 +14,7 @@ fi
IUSE=""
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtsensors/qtsensors-5.15.2.ebuild b/dev-qt/qtsensors/qtsensors-5.15.2-r1.ebuild
index 66b45058d70a..c28fdfe54405 100644
--- a/dev-qt/qtsensors/qtsensors-5.15.2.ebuild
+++ b/dev-qt/qtsensors/qtsensors-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Hardware sensor access library for the Qt5 framework"
@@ -14,9 +15,9 @@ fi
IUSE="qml"
RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdbus-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdbus-${QT5_PV}*
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
DEPEND="${RDEPEND}"
diff --git a/dev-qt/qtserialbus/qtserialbus-5.15.2.ebuild b/dev-qt/qtserialbus/qtserialbus-5.15.2-r1.ebuild
index 2b783f499663..0d8fd68fa6e0 100644
--- a/dev-qt/qtserialbus/qtserialbus-5.15.2.ebuild
+++ b/dev-qt/qtserialbus/qtserialbus-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Qt module to access CAN, ModBus, and other industrial serial buses and protocols"
@@ -13,8 +14,8 @@ fi
IUSE=""
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtserialport-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtserialport-${QT5_PV}*
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtserialport/qtserialport-5.15.2.ebuild b/dev-qt/qtserialport/qtserialport-5.15.2-r1.ebuild
index dbbb302a3f98..26e5eb53bd00 100644
--- a/dev-qt/qtserialport/qtserialport-5.15.2.ebuild
+++ b/dev-qt/qtserialport/qtserialport-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Serial port abstraction library for the Qt5 framework"
@@ -13,7 +14,7 @@ fi
IUSE=""
DEPEND="
- ~dev-qt/qtcore-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
virtual/libudev:=
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtwebchannel/qtwebchannel-5.15.2.ebuild b/dev-qt/qtwebchannel/qtwebchannel-5.15.2-r1.ebuild
index b5486b450fcb..1f5019a95f50 100644
--- a/dev-qt/qtwebchannel/qtwebchannel-5.15.2.ebuild
+++ b/dev-qt/qtwebchannel/qtwebchannel-5.15.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit qt5-build
DESCRIPTION="Qt5 module for integrating C++ and QML applications with HTML/JavaScript clients"
@@ -13,8 +14,8 @@ fi
IUSE="qml"
DEPEND="
- ~dev-qt/qtcore-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
+ =dev-qt/qtcore-${QT5_PV}*
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtwebview/qtwebview-5.15.2-r1.ebuild b/dev-qt/qtwebview/qtwebview-5.15.2-r2.ebuild
index d17dd95908f8..a1b3c1180fbd 100644
--- a/dev-qt/qtwebview/qtwebview-5.15.2-r1.ebuild
+++ b/dev-qt/qtwebview/qtwebview-5.15.2-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit qt5-build
@@ -14,9 +14,9 @@ fi
IUSE=""
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
=dev-qt/qtwebengine-${PV}*:5
"
RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtx11extras/qtx11extras-5.15.2.ebuild b/dev-qt/qtx11extras/qtx11extras-5.15.2-r1.ebuild
index 40e88544ff0d..0174763a58f6 100644
--- a/dev-qt/qtx11extras/qtx11extras-5.15.2.ebuild
+++ b/dev-qt/qtx11extras/qtx11extras-5.15.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit qt5-build
@@ -14,9 +14,9 @@ fi
IUSE=""
RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[X]
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*[X]
"
DEPEND="${RDEPEND}
- test? ( ~dev-qt/qtwidgets-${PV} )
+ test? ( =dev-qt/qtwidgets-${QT5_PV}* )
"