summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-19 15:35:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-19 15:41:47 +0200
commitfd6fb46a681e8d3a3628fb13c92d459a022e1acd (patch)
tree9d8fafcdf14cef2401c015c5098bddc6bc65b23d /dev-qt
parentprofiles/desc/ada_target.desc: remove support for <gnat_2019 (diff)
downloadgentoo-fd6fb46a681e8d3a3628fb13c92d459a022e1acd.tar.gz
gentoo-fd6fb46a681e8d3a3628fb13c92d459a022e1acd.tar.bz2
gentoo-fd6fb46a681e8d3a3628fb13c92d459a022e1acd.zip
dev-qt/qtwebengine: Drop vulnerable 5.15.2_p20210625
Bug: https://bugs.gentoo.org/810781 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/Manifest1
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.0-disable-fatal-warnings.patch10
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.2_p20210625.ebuild224
3 files changed, 0 insertions, 235 deletions
diff --git a/dev-qt/qtwebengine/Manifest b/dev-qt/qtwebengine/Manifest
index c4c1b9d408f9..b4883d999d52 100644
--- a/dev-qt/qtwebengine/Manifest
+++ b/dev-qt/qtwebengine/Manifest
@@ -1,3 +1,2 @@
DIST qtwebengine-5.15.2-chromium87-ppc64le.tar.xz 28536 BLAKE2B 98f8e01e7026d9df1d30ae453d4394d3c4ad04c0620a2496235d45f5f1080c2280e040826cde7f72d9771bfc80d0c3df56c9dcbe4f763cec432ad56de37d64c5 SHA512 c90a76f44a9d720624016fd082ab3036f12e13b9789e869ebaf5e4774afca7d4187faf187f365f696d1a7eda05ca75516556ee9d291cdb3408d57cc4b23e2654
-DIST qtwebengine-5.15.2_p20210625.tar.xz 320144708 BLAKE2B cd11e69a34ff0fa07d26262906a12304c39a12575024d61db18bc696284e9c5700090e5bfed217c89d2c8eac49b0ccb7d7ee0ba716ec3a81878de1301566884d SHA512 517a8cdaff684894456db8cfb5cfca412b8764e7035623d8190d9a06f6995742097a53eb67329d12bf8dc0a56372f7d09a54532ba804a5bff245ca8ef042a4e1
DIST qtwebengine-5.15.2_p20210824.tar.xz 320214264 BLAKE2B fe611805107822f495e0921de4fc9a8737bd3238a332e03d27421a3fd14dc1417c1d69e9ec5e9f6bf922f98045cbdf9ee2c76621db988c8b1e6e0e90b2c6dc7e SHA512 3a5f9ef45ba488aee601e092d1c4a5f707a854d5b9f0a5e62cb88dcdf280163182abc98b0a55b28591e81e18b5147142d404dcdc92feb61414ce2d4ce0d2dca6
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.0-disable-fatal-warnings.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.0-disable-fatal-warnings.patch
deleted file mode 100644
index af602855b129..000000000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.15.0-disable-fatal-warnings.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/buildtools/config/common.pri 2020-02-28 22:21:09.341072620 +0200
-+++ b/src/buildtools/config/common.pri 2020-02-28 22:20:26.702399180 +0200
-@@ -25,6 +25,7 @@
- strip_absolute_paths_from_debug_symbols=false \
- toolkit_views=false \
- treat_warnings_as_errors=false \
-+ fatal_linker_warnings=false \
- use_allocator_shim=false \
- use_allocator=\"none\" \
- use_custom_libcxx=false \
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.2_p20210625.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.2_p20210625.ebuild
deleted file mode 100644
index 3b18dfa1b720..000000000000
--- a/dev-qt/qtwebengine/qtwebengine-5.15.2_p20210625.ebuild
+++ /dev/null
@@ -1,224 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-QTVER=$(ver_cut 1-3)
-inherit estack flag-o-matic multiprocessing python-any-r1 qt5-build
-
-DESCRIPTION="Library for rendering dynamic web content in Qt5 C++ and QML applications"
-HOMEPAGE="https://www.qt.io/"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
- if [[ ${PV} == ${QTVER}_p* ]]; then
- SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
- S="${WORKDIR}/${P}"
- QT5_BUILD_DIR="${S}_build"
- fi
-else
- EGIT_BRANCH="5.15"
- EGIT_REPO_URI=(
- "https://code.qt.io/qt/${QT5_MODULE}.git"
- "https://github.com/qt/${QT5_MODULE}.git"
- )
- inherit git-r3
-fi
-
-# patchset based on https://github.com/chromium-ppc64le releases
-SRC_URI+=" ppc64? ( https://dev.gentoo.org/~gyakovlev/distfiles/${PN}-5.15.2-chromium87-ppc64le.tar.xz )"
-
-IUSE="alsa bindist designer geolocation +jumbo-build kerberos pulseaudio +system-ffmpeg +system-icu widgets"
-REQUIRED_USE="designer? ( widgets )"
-
-RDEPEND="
- app-arch/snappy:=
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- dev-libs/expat
- dev-libs/libevent:=
- dev-libs/libxml2[icu]
- dev-libs/libxslt
- dev-libs/re2:=
- ~dev-qt/qtcore-${QTVER}
- ~dev-qt/qtdeclarative-${QTVER}
- ~dev-qt/qtgui-${QTVER}
- ~dev-qt/qtnetwork-${QTVER}
- ~dev-qt/qtprintsupport-${QTVER}
- ~dev-qt/qtwebchannel-${QTVER}[qml]
- media-libs/fontconfig
- media-libs/freetype
- media-libs/harfbuzz:=
- media-libs/lcms:2
- media-libs/libjpeg-turbo:=
- media-libs/libpng:0=
- >=media-libs/libvpx-1.5:=[svc(+)]
- media-libs/libwebp:=
- media-libs/mesa[egl,X(+)]
- media-libs/opus
- sys-apps/dbus
- sys-apps/pciutils
- sys-libs/zlib[minizip]
- virtual/libudev
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libxkbfile
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- alsa? ( media-libs/alsa-lib )
- designer? ( ~dev-qt/designer-${QTVER} )
- geolocation? ( ~dev-qt/qtpositioning-${QTVER} )
- kerberos? ( virtual/krb5 )
- pulseaudio? ( media-sound/pulseaudio:= )
- system-ffmpeg? ( media-video/ffmpeg:0= )
- system-icu? ( >=dev-libs/icu-69.1:= )
- widgets? (
- ~dev-qt/qtdeclarative-${QTVER}[widgets]
- ~dev-qt/qtwidgets-${QTVER}
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- dev-util/gperf
- dev-util/ninja
- dev-util/re2c
- net-libs/nodejs[ssl]
- sys-devel/bison
- sys-devel/flex
- ppc64? ( >=dev-util/gn-0.1807 )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.15.0-disable-fatal-warnings.patch" # bug 695446
- "${FILESDIR}/${PN}-5.15.2_p20210224-chromium-87-v8-icu68.patch" # downstream, bug 757606
- "${FILESDIR}/${PN}-5.15.2_p20210224-disable-git.patch" # downstream snapshot fix
- "${FILESDIR}/${PN}-5.15.2_p20210406-glibc-2.33.patch" # by Fedora, bug 769989
- "${FILESDIR}/${PN}-5.15.2_p20210521-gcc11.patch" # by Fedora, bug 768261
-)
-
-pkg_preinst() {
- elog "This version of Qt WebEngine is based on Chromium version 87.0.4280, with"
- elog "additional security fixes from newer versions. Extensive as it is, the"
- elog "list of backports is impossible to evaluate, but always bound to be behind"
- elog "Chromium's release schedule."
- elog "In addition, various online services may deny service based on an outdated"
- elog "user agent version (and/or other checks). Google is already known to do so."
- elog
- elog "tldr: Your web browsing experience will be compromised."
-}
-
-src_unpack() {
- # bug 307861
- eshopts_push -s extglob
- if is-flagq '-g?(gdb)?([1-9])'; then
- ewarn
- ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
- ewarn "You may experience really long compilation times and/or increased memory usage."
- ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
- ewarn
- fi
- eshopts_pop
-
- case ${QT5_BUILD_TYPE} in
- live) git-r3_src_unpack ;&
- release) default ;;
- esac
-}
-
-src_prepare() {
- if [[ ${PV} == ${QTVER}_p* ]]; then
- # This is made from git, and for some reason will fail w/o .git directories.
- mkdir -p .git src/3rdparty/chromium/.git || die
-
- # We need to make sure this integrates well into Qt 5.15.2 installation.
- # Otherwise revdeps fail w/o heavy changes. This is the simplest way to do it.
- sed -e "/^MODULE_VERSION/s/5.*/${QTVER}/" -i .qmake.conf || die
- fi
-
- # QTBUG-88657 - jumbo-build could still make trouble
- if ! use jumbo-build; then
- sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \
- src/buildtools/config/common.pri || die
- fi
-
- # bug 620444 - ensure local headers are used
- find "${S}" -type f -name "*.pr[fio]" | \
- xargs sed -i -e 's|INCLUDEPATH += |&$${QTWEBENGINE_ROOT}_build/include $${QTWEBENGINE_ROOT}/include |' || die
-
- if use system-icu; then
- # Sanity check to ensure that bundled copy of ICU is not used.
- # Whole src/3rdparty/chromium/third_party/icu directory cannot be deleted because
- # src/3rdparty/chromium/third_party/icu/BUILD.gn is used by build system.
- # If usage of headers of bundled copy of ICU occurs, then lists of shim headers in
- # shim_headers("icui18n_shim") and shim_headers("icuuc_shim") in
- # src/3rdparty/chromium/third_party/icu/BUILD.gn should be updated.
- local file
- while read file; do
- echo "#error This file should not be used!" > "${file}" || die
- done < <(find src/3rdparty/chromium/third_party/icu -type f "(" -name "*.c" -o -name "*.cpp" -o -name "*.h" ")" 2>/dev/null)
- fi
-
- qt_use_disable_config alsa webengine-alsa src/buildtools/config/linux.pri
- qt_use_disable_config pulseaudio webengine-pulseaudio src/buildtools/config/linux.pri
-
- qt_use_disable_mod designer webenginewidgets src/plugins/plugins.pro
-
- qt_use_disable_mod widgets widgets src/src.pro
-
- qt5-build_src_prepare
-
- # we need to generate ppc64 stuff because upstream does not ship it yet
- if use ppc64; then
- einfo "Patching for ppc64le and generating build files"
- eapply "${FILESDIR}/qtwebengine-5.15.2-enable-ppc64.patch"
- pushd src/3rdparty/chromium > /dev/null || die
- eapply -p0 "${WORKDIR}/${PN}-ppc64le"
- popd > /dev/null || die
- pushd src/3rdparty/chromium/third_party/libvpx > /dev/null || die
- mkdir -vp source/config/linux/ppc64 || die
- mkdir -p source/libvpx/test || die
- touch source/libvpx/test/test.mk || die
- ./generate_gni.sh || die
- popd >/dev/null || die
- fi
-}
-
-src_configure() {
- export NINJA_PATH=/usr/bin/ninja
- export NINJAFLAGS="${NINJAFLAGS:--j$(makeopts_jobs) -l$(makeopts_loadavg "${MAKEOPTS}" 0) -v}"
-
- local myqmakeargs=(
- --
- -no-build-qtpdf
- -printing-and-pdf
- -system-opus
- -system-webp
- $(usex alsa '-alsa' '-no-alsa')
- $(usex bindist '-no-proprietary-codecs' '-proprietary-codecs')
- $(usex geolocation '-webengine-geolocation' '-no-webengine-geolocation')
- $(usex kerberos '-webengine-kerberos' '-no-webengine-kerberos')
- $(usex pulseaudio '-pulseaudio' '-no-pulseaudio')
- $(usex system-ffmpeg '-system-ffmpeg' '-qt-ffmpeg')
- $(usex system-icu '-webengine-icu' '-no-webengine-icu')
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
-
- # bug 601472
- if [[ ! -f ${D}${QT5_LIBDIR}/libQt5WebEngine.so ]]; then
- die "${CATEGORY}/${PF} failed to build anything. Please report to https://bugs.gentoo.org/"
- fi
-}