summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-31 14:11:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-31 15:56:47 +0200
commit7e388e23576be8e3a9d3bd5f1a13a8ae536157e3 (patch)
treef65bd835fe81b8671f88d2947e4834c1ccf641fb /dev-ros/actionlib/actionlib-1.11.15.ebuild
parentros-meta/qt_gui_core: Bump to 0.3.11. (diff)
downloadgentoo-7e388e23576be8e3a9d3bd5f1a13a8ae536157e3.tar.gz
gentoo-7e388e23576be8e3a9d3bd5f1a13a8ae536157e3.tar.bz2
gentoo-7e388e23576be8e3a9d3bd5f1a13a8ae536157e3.zip
dev-ros/actionlib: bump to 1.11.15
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-ros/actionlib/actionlib-1.11.15.ebuild')
-rw-r--r--dev-ros/actionlib/actionlib-1.11.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/actionlib/actionlib-1.11.15.ebuild b/dev-ros/actionlib/actionlib-1.11.15.ebuild
new file mode 100644
index 000000000000..72617b6f8b23
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+"